1

I have exported customers from a magento site. Some customers have confirmed email verification while some have not.

In the exported CSV file, i can see that the customers who have confirmed their account have value set to null in "confirmation" field while those who have not confirmed their email have some hash value set in "confirmation" field.

Now that i import the the customer to another magento site and try to login, i get the message: "user email not confirmed".

When i searched for value for confirmation attribute in database for the particular customer_entity, i see that some hash value is set for the confirmation field. so when i set the value to null, the login works fine for the customer who have their email confirmation done.

But this won't be appropriate when i have three thousand customer to migrate.

What would be a proper solution for this? Am i doing something wrong in the import/export process?

0

i think this issue is because of incomplete data export or import

follow the following Steps to run it successfully.

1) Import the data in Blank DB

2) change database name in local.xml

3) change url in core_config_data

4) clear cache and session

All done. Now you can see frontend and login into admin panel as well.

I hope this will help you.

  • I have followed the steps you mentioned to create a copy of my live to local site but it is just the customer from live site i need to move to local site that is not working. – Armed Dec 25 '15 at 12:23
  • go to System menu>Configuration>Customer Configuration button in the Customers section on the left>Create New Account Options panel on the right>Require Emails Confirmation drop-down menu. Set the drop-down menu to No to disable email verification and click on the Save Config button in the top right corner and check login...i hope this trik will work. – denish vachhani Dec 25 '15 at 12:29
  • Thank you for your answer, but i also need the customers to have email verification who have not done their verification. – Armed Dec 25 '15 at 12:34
  • yes they will be there but this will disable checking in local about customer with email varification so you can login. – denish vachhani Dec 25 '15 at 12:37
  • yes, but the thing is i have upgraded version of live site in my local. So i need the customer login and validation as it is as in live site so i can upload my local version to the live site. – Armed Dec 25 '15 at 12:48
0

Two things:

  1. Check if both hash key(s) are the same (look into: app/etc/local.xml)
  2. Check your customer configuration and verify that the option 'Require Email Confirmation' is set to NO

enter image description here

  • Thank you for your answer, simply setting require email confirmation to no saving configuration and setting it back to yes again and everything is working good. – Armed Dec 28 '15 at 17:45
0

Looking your comments I can see what you actually need.

Try to re-export/import with the attribute 'customer_activated' if you can't you'll need to export and import these values from mysql that way:

Find the attribute_id:

select * from eav_attribute where attribute_code = 'customer_activated' and entity_type_id = 1

Then use that id (in my case 476) to get the 'cutomer_activated' value for each customer:

SELECT 
 ce.entity_id,
 ce.email,
 cei.value as customer_activated  
FROM customer_entity AS ce 
LEFT JOIN customer_entity_int AS cei 
  ON cei.entity_id = ce.entity_id 
WHERE attribute_id = 476 
GROUP BY ce.entity_id

Well at this point you should have all activation data ready to use then you can do several things with that, some options are:

  1. (fast) Copy query results into a CSV file and run an import (in append mode) using the "import/export" tool.
  2. (little bit slow) Copy query results into a CSV file and do a data-flow profile import
  3. (complex.. and slow too)
    • Create a php file (somewhere to run on demand)
    • Copy query results into an array
    • Load a customer collection
    • Set values for each customer $customer->setCustomerActive(?)
0

simply setting require email confirmation to no saving configuration and setting it back to yes again and everything is working good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.