1

I have upgraded my magento to 1.9.2 and had 404 on Home page and white screen (blank page) on /admin. Home page I have fixed, but i have no idea what is the trouble with admin page.

I have cleared cache, checked logs... Nothing special. Who can help please?

  • check php logs, something is broken. 404 maybe your store code lost, or htaccess and rewrites not working – MagenX Dec 24 '15 at 15:16
  • I already fixed 404 error. Now I try to understand why there is white page on /admin – MageLover Dec 24 '15 at 15:27
1

First enable Developer mode in your .htaccess file, add the following at the end of the file:

SetEnv MAGE_IS_DEVELOPER_MODE "true"

Next edit index.php and uncomment the line:

#ini_set('display_errors', 1);

Line referenced:

Ensure var/ is writeable by the webserver.

Enabling developer mode and display of errors you should now see the exception/error when attempting to login to the admin page vs a blank screen.

  • I wiil try it now, but dont think it could help me.. Developer mode also enabled. – MageLover Dec 24 '15 at 15:53
  • 1
    oh, now I have press "return to admin" from downloader again and... "Fatal error: Call to a member function setActive() on a non-object in /app/code/core/Mage/Adminhtml/Controller/Action.php on line 104 – MageLover Dec 24 '15 at 16:13
  • Try re uploading all files located in app/design/adminhtml/default/default/layout/ from a downloaded copy of the same version you installed via downloader (1.9.2.x) from magentocommerce.com – B00MER Dec 24 '15 at 16:30
  • I must do it manually or I can go to downloader and reinstall "Mage_Core_Adminhtml"? – MageLover Dec 24 '15 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.