2

we have a LIVE magento site from last one year.

recently we are facing very difficult problem from Browser cookies.

Frontend is not opening and keep on loading and never load.

we are using HTTPS for secure pages.

we are facing problem in chrome, mozilla , opera, safari and all other browsers.

1)If we clear the BROWSER COOKIES, than its working.

2)If we clear the VAR/SESSION folder, than its working.

3)If we open the site in freshly installed browsers, its working for some time. again same problem. as cookies will occupy after visiting site.

There is no problem in Backend

we followed this : https://stackoverflow.com/questions/15491819/magento-admin-login-not-working-in-chrome-but-works-fine-for-firefox but it did't worked.

IS it related to only cookies problem or our template code problem?

enter image description here

we face issue as in images sometimes.enter image description here

enter image description here

2

Are you getting double cookies set? Bare Domain AND Subdomain? One for example.com and one for www.example.com?

I found on our site, we needed to do an .htaccess redirect to force everything to whichever was our choice for the website base server domain or we would run afoul of session hijack as the site would respond to one, set a cookie and immediately redirect to the other. Once cookies were double-set things came to grief.

Magento's settings for Cookie Path and domain did not alleviate it, even when correctly set.

  • Is there any way that we can check whether we set double cookies or not ? – Baby in Magento Dec 28 '15 at 5:12
  • Look in your browser cookie store and examine the contents. Frontend and Admin cookies will be duplicated. – Fiasco Labs Dec 28 '15 at 17:12
  • we dont have any sub - domain in our server for our main domain. – Baby in Magento Feb 16 '16 at 19:09
  • i am checking here : prntscr.com/a4sp53 if our site name is xyz.com, than it creating cookies only for xyz.com, its not creating cookies for www.xyz.com than its fine right ? – Baby in Magento Feb 18 '16 at 10:21
1

We experienced a very similar issue pages were loading blank for very specific sessions, it was almost impossible to recreated in local environments. It turned out to be an infinite loop caused by the trigger_recollect attribute on the carts (quotes) of these sessions. See this thread for more info:

Customer stuck in an endless loop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.