7

I'm on 1.9.2.1 and am new to development. My new order emails are not sending so I installed AOE Scheduler and I get the error:

No heartbeat task found. Check if cron is configured correctly. (See Instructions)

On the instruction page it gives me these commands:

sudo crontab -u ultima -e

&

* * * * * ! test -e /home/website/public_html/maintenance.flag && /bin/bash /home/website/public_html/scheduler_cron.sh --mode always


* * * * * ! test -e /home/website/public_html/maintenance.flag && /bin/bash /home/website/public_html/scheduler_cron.sh --mode default

I'm not really sure what to do with these, I took a back up of everything and SSH'd in with PuTTY(windows 10).

When I drop the first one in I get the error:

Website is not in the sudoers file. This incident will be reported.

The second ones give me:

"-bash: access-logs: command not found"

I'm not really sure what else to do? Can anyone help a new to dev guy out?

I only have cpanel/whm access to the hosting server.

  • Just wanted to add that I tried just "crontab -e" it brings me into the file "/tmp/crontab.TUvxAF". I added those two lines and saved. Still getting the error no heartbeat so I'm guessing I did something wrong. – user3330820 Dec 22 '15 at 20:23
  • 1
    magento.stackexchange.com/questions/67646/… check this or even try contacting your hosting providers to set up cron job – Baby in Magento Dec 22 '15 at 20:45
  • @BabyinMagento Appreciate the response. That did in fact help me and AOE Scheduler is working. Thanks! – user3330820 Dec 22 '15 at 22:16
4

credits : @Yorrd

You don't need to execute many commands, the most important thing is that you edit your crontab file. I don't know how this works on Amazon's servers, usually you can do it via crontab -e though (e for edit).

In that file you need to add a new rule which calls the cron.php every so often. The format of this is (borrowed from your link):

* * * * *  /bin/sh /absolute/path/to/magento/cron.sh

Format of this: The first 5 stars stand for minutes, hours, days, weeks and months. Then the shell which you want to run your script (just use /bin/sh) and finally the path to your cron.sh which you need to look up yourself (in your Magento root usually).

We're doing this every minute, because cron.php will take care which scripts to run when and just needs a heartbeat.

or you may contact your hosting providers.

If you successfully add this line as I described above and Amazon didn't disable cron jobs or something, this should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.