2

In my system log I am getting below error. Please help me to resolve it.

ERR (3): Warning: include(Mage/Searchautocomplete/Model/Processor.php): failed to open stream: No such file or directory in

2
  • It seems like a corrupted install of a 3rd party module with the name "Searchautocomplete". Consult with the module developer regarding this.
    – Prateek
    Dec 22, 2015 at 7:44
  • Compilation enable or disabled in admin side?
    – Abdul
    Dec 22, 2015 at 7:48

2 Answers 2

3

If this is a Cmsmart extension (commonly found in Template Monster templates), more specifically Cmsmart AjaxSearch, then try updating

app/code/local/Cmsmart/Ajaxsearch/etc/config.xml 

Change: <class>searchautocomplete/processor</class> (around line 29)
to: <class>ajaxsearch/processor</class>

If that doesn't do the trick, check to see if your site is compiled and, if so, disable compilation and clear the compiled version.

Try this:

In the Admin panel, disable Compilation under System>Tools>Compilation.

In the command line, from the root directory, php shell/compiler.php --clear. This will clear the compiled files (disabling is not necessarily enough).

Then clear cache and refresh your pages a couple times to see if the error message persists in system.log.

0
0

This happens because you enabled the Magento Compilation and the code was not compiled properly after the new installation / upgrade.

To solve this issue you need to disable Magento Compilation temporarily before any module installation / upgrade. To do this go to System > Tools > Compilation.

As soon the installation / upgrade went success, enable Magento Compilation same as before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.