0

For debugging our site , in app/etc/local.xml we set :

<disable_local_modules>true</disable_local_modules>

but now we are getting this error :

Fatal error: Class 'Mage_Themeframework_Helper_Theme' not found in /app/Mage.php on line 547

backend is working fine

  • have you added any custom extensions? – Abdul Dec 21 '15 at 12:47
  • yes we have lot of extensions. – Baby in Magento Dec 21 '15 at 12:48
  • Themeframework extensions available? – Abdul Dec 21 '15 at 12:48
  • yes, all theme related files are enable – Baby in Magento Dec 21 '15 at 12:49
  • Themeframework_Helper_Theme file is missing – Abdul Dec 21 '15 at 12:51
1

You have disabled the all the local modules. And it seems your local helper is calling from some where in your code and it is giving helper missing error.

Try to search helper('themeframework/theme') in all code and see if it is calling from any file other then module itself.

  • i will check it – Baby in Magento Dec 21 '15 at 12:55
  • except theme related files, this line is not present anywhere in the code – Baby in Magento Dec 21 '15 at 13:19
  • you will need to check it in app/code/community also. – Akhilesh Patel Dec 21 '15 at 13:20
  • i checked in complete site code files using ssh using this command : fgrep -r themeframework/theme – Baby in Magento Dec 21 '15 at 13:22
  • can you check if compilation is on? – Akhilesh Patel Dec 21 '15 at 13:23
1

If your are disable local module but some places using your module Helper file $this->helper('themeframework/theme')

Please find your helper file other module and comment this helper.

  • I don' find any difference with my answer!!! – Akhilesh Patel Dec 21 '15 at 12:58
  • except theme related files, this line is not present anywhere in the code – Baby in Magento Dec 21 '15 at 13:19
1

You have wrongly defined the helper class group name in config.xml or wrongly call helper call.

You need to check setting at config.xml

<global>
  <helpers>
    <themeframework> <!-- this call module helper class group name -->
      <class>EM_Themeframework_Helper</class>
    </themeframework>
  </helpers>
</global>

Also global config file name should be changed accordingly.

Also check compiler

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.