I've successfully added attributes and attribute sets to the store I'm working on, however I'm running into trouble with creating associations between the attributes and attribute sets.

When I check an attribute set in the Magento backend, the Groups column is completely empty, and all the attributes appear to be available in the Unassigned Attributes column.

This is a sample from my csv for creating associations:

attribute_set_name  attribute_code  attribute_group_name
AC Gearmotor        FullLoadAmps    General
AC Gearmotor        MountingStyle   General
AC Gearmotor        RPM             General
AC Gearmotor        Torque          General

These are my settings in Magmi for the Attribute association import options:

*,meta_title,Meta Information
*,meta_keyword,Meta Information
*,meta_description,Meta Information
*,is_recurring,Recurring Profile
*,recurring_profile,Recurring Profile
*,gift_message_available,Gift Options

Create attribute associations from CSV which are not in database

Update attribute associations from CSV which are already in database

Which generates the following/similar error for each association which I attempt:

Attribute Set Importer v0.0.2 - Exception in update/insert loop for entity 
'attribute association' in record no 1: SQLSTATE[23000]: Integrity constraint violation: 
1452 Cannot add or update a child row: a foreign key constraint fails (`brennerf_6b6AnYRQ`.
`i2r7_eav_entity_attribute`, CONSTRAINT `FK_917A5725E0970D5A68B169EEBCDED200` 
FOREIGN KEY (`attribute_group_id`) REFERENCES `i2r7_eav_attribute_group` 

record data:Array
  [attribute_group_name] => General
  [entity_type_id] => 4
  [attribute_set_id] => 23683
  [attribute_id] => 515

original record data:Array
  [attribute_set_name] => AC Gearmotor
  [attribute_code] => FullLoadAmps
  [attribute_group_name] => General
  [entity_type_id] => 4

1 Answer 1


Appears I had missed a step, and did not add the magmi:groups column to the attribute set import csv.

  • 1
    Ca you elaborate on what you mean?
    – johnsnails
    Jun 15, 2016 at 4:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.