1

I have disabled the module Inchoo_Notes in the app/etc/modules:

<?xml version="1.0"?>
<config>
    <modules>
        <Inchoo_Notes>
            <active>false</active>
            <codePool>community</codePool>
        </Inchoo_Notes>
    </modules>
</config>

I get the following error, when I go to configuration of admin panel:

( ! ) Fatal error: Class 'Mage_Inchoo_Notes_Helper_Data' not found in Unknown on line 0
Call Stack
#   Time    Memory  Function    Location
1   0.1100  272464  {main}( )   ..\index.php:0
2   2.4100  569040  Mage::run( ???, ???, ??? )  ..\index.php:83
3   2.4200  1607016 Mage_Core_Model_App->run( ??? ) ..\Mage.php:684
4   9.0870  13877440    Mage_Core_Controller_Varien_Front->dispatch( )  ..\App.php:365
5   9.8670  27413680    Mage_Core_Controller_Varien_Router_Standard->match( ??? )   ..\Front.php:172
6   9.9270  27414968    Mage_Core_Controller_Varien_Action->dispatch( ??? ) ..\Standard.php:254
7   15.3740 28651128    Mage_Adminhtml_System_ConfigController->editAction( )   ..\Action.php:418
8   16.3340 34068944    Mage_Adminhtml_Block_System_Config_Tabs->initTabs( )    ..\ConfigController.php:104
9   41.2180 66104432    Mage::helper( ??? ) ..\Tabs.php:92
Variables in local scope (#9)

$helperClass =string 'Mage_Inchoo_Notes_Helper_Data' (length=29)

$name =string 'inchoo_notes' (length=12)

$registryKey =string '_helper/inchoo_notes' (length=20)

I debugged the code and I am seeing that in configuration it is trying to load the tab of Inchoo notes still in here:

\app\code\core\Mage\Adminhtml\Block\System\Config\Tabs.php

foreach ($tabs as $tab) {
        $helperName = $configFields->getAttributeModule($tab);
        $label = Mage::helper($helperName)->__((string)$tab->label);

        $this->addTab($tab->getName(), array(
            'label' => $label,
            'class' => (string) $tab->class
        ));
    }

and then I debugged further which goes here in Mage.php:

public static function helper($name)
{
    $registryKey = '_helper/' . $name;
    if (!self::registry($registryKey)) {
        $helperClass = self::getConfig()->getHelperClassName($name);
        self::register($registryKey, new $helperClass);
    }
    return self::registry($registryKey);
}

I am seeing that self::registry($registryKey) is false and therefore it goes to $helperClass = self::getConfig()->getHelperClassName($name); and instead of having Inchoo_Notes_Helper I will have Mage_Inchoo_Notes_Helper_Data

why is that????? why even it tries to load it! when I said disable this module? I am frustrated.

by the way cache is disabled, I flushed the cache so it is not a solution. Also I have the helper for this module, the helper is not missing, therefore this is not a solution either.

1

What happens is, that the helper is still used, I would assume, Magento tries to translate certain strings in system.xml or adminhtml.xml or some layout.xml file.

To my mind come two possiblities:

  1. Your assumption, the cache is flushed/disabled is wrong
  2. You use somewhere translate="some nodename" module="inchoo_notes" in an xml file

Or is is used somewhere else.

The easiest is to grep for it (and grep in var/cache too, so you see, when a cache file includes it (there should be none)

  • absolutely I had translate="some nodename" but I removed them and it did not work still, why translate would make trouble? – Nickool Dec 18 '15 at 1:09
  • I did not know grep can be also used in windows, I should try that but I go to var/cache and delete everything, cache should not be the issue – Nickool Dec 18 '15 at 1:16
  • if I rename Inchoo to _Inchoo, error will go away but if i rename Notes to _Notes the error still remains! – Nickool Dec 18 '15 at 1:24
  • I installed grep and searched for notes in cache, it is not there – Nickool Dec 18 '15 at 1:29
  • I believe you, but what you describe doesn't make sense. Obviously the module is still active. But changing the one name of the directory doesn't solve but the other does? Sounds crazy. No idea, sorry. – Fabian Blechschmidt Dec 18 '15 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.