1

I have tried to install the following sample components on my local VM with well working Magento 2.0;

sample-module-form-uicomponent
sample-module-newpage
sample-module-servicecontract-new
sample-module-webflow

from here: https://github.com/magento/magento2-samples

The installation with bin/magento setup:upgrade was successfully and the modules are avaialable in the admin panel. But if I try to open the example pages I still get "404 Not found". I used the URL from the readmes e.g. in my case 127.0.0.1/magento2/webflow/firstpage I have installed the latest version including registration.php. Developer mode is enabled, too. Same errors when I try to create custom modules. Any ideas? Thanks.

  • Do these sample modules appear in app/etc/config.php? Also since you had a previous installation, please clean your var/di and var/generation folders as well as cache. – Maddy Dec 15 '15 at 19:55
  • @Maddy Cache is cleaned and deactivated. There is no previous installation. Yes, the extensions do appear in the config.php as well as in the admin panel under Store->Configuration->Advanced->Advanced. – Tenobi Dec 15 '15 at 20:28
  • A new magento installation on the same system has same issues. First installation was from developer branch, the new from 2.0. Still the same – Tenobi Dec 15 '15 at 20:30
  • Can you provide in depth steps, since we are having trouble reproducing this issue. How did you deploy magento? downloaded zip from magento.com, git clone or composer create project? For the sample modules, did you use composer require, or git clone and then copy them to app/code? If you copied, what path did you copy to? – Maddy Dec 15 '15 at 21:11
  • See my answer below. A combination of uncomplete instructions and a magento beginner. – Tenobi Dec 15 '15 at 21:54
0

Shame on me, i have posted the question in magento-sample github issues, too. https://github.com/magento/magento2-samples/issues/47

I have got a hint that solves my problem. Text in copy:

Blockquote Okay, I think I found the issue. I did not know that I had to rename the "sample-module-..." directory to "SampleWebFlow" as defined inside registration.php. I am not familar with magento and did not recognize the relation... As far as I can see the renaming is not included in the readmes.

  • Thanks for pointing this out. We'll improve the READMEs soon. – Steve Johnson Dec 16 '15 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.