I've installed Magmi, configured it and installed it too

Iam able to get products into my site, BUT prob is: Iam unable to see any image, since image urls all are from remote..

My image url looks like: http://www.fashion58.com/itemimages/SMS032-navy.jpg

Even iam not sure whether to change 'image renaming' or not, BUT at end all I need is : my remore image urls should able to display in my site..

Awaiting response!

EDITED: My feed Column names are: store,websites,type,attribute_set,is_affiliate_product,status,visibility,qty,is_in_stock,tax_class_id,weight,name,meta_keyword,description,sku,manufacturer,price,merchant_buy_link,image,main_category,color,for,shoe_type,short_description,thumbnail,category_ids,merchant_name,merchant_id,small_image

A) and Do I really need to use 'Image attributes processor' plugin inorder to display remote image urls? or else Magmi just enough to render images for remote image urls?

B) If YES for 'Image attributes processor', what settings I need to change in it?

C) What could be still wrong?

  • please anyone can answer this..? – Joey River Oct 14 '13 at 10:26
  • Hey Joey, I followed your sample URL and it redirects to the product detail page, it's not an image. Can you please bring more light on 1) how exactly your image URLs look 2) why you need image renaming – Alexey Shchur Oct 14 '13 at 14:51
  • @Rob : Iam sorry i given a wrong link above.. now i given my image link..(pls kindly check above again) actually i dont know whether i should change 'image renaming' or someother seting.. All I need is: My remote image urls should able to display.. – Joey River Oct 14 '13 at 14:59
  • @Rob my feed has remote image urls, and column names related to image are: remote_image_url and remote_thumbnail_image_url – Joey River Oct 14 '13 at 15:28
  • 4
    This question appears to be off-topic because it is about a third party module, please contact them directly for support. – David Manners May 19 '14 at 17:19

Your link that your image is at should be entered in your .csv file as:


And yes the image attribute checkbox should be selected when uploading images. There are no settings for this option, simply a checkbox to select?

For more info work through below url:


  • I just tried as you said, i mean i removed "www" for all images an re-imported again, and also checked for plugin "Image attributes processor" , even after doing all these iam unabe to get images for products... Not understanding what to do :( – Joey River Oct 14 '13 at 18:10
  • Hi Joey, it's really hard to work out what's going wrong. Sounds like you are doing everything correct now to be honest. Have you had success at pulling in images locally from your media/import folder? I recall it was "fiddly" to configure pulling in images via Magmi remotely around 9 months ago, but the method I've described above is what we use now. We pull from 3rd party sites regularly rather than our own. Might be wrong, but it could be because your image labels are missing? E.g. image_label, small_image_label, thumbnail_label, you could try adding those in, product name as image labels. – MagentoMac Oct 14 '13 at 22:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.