0

I reindexed all data successfully with SSH php -f indexer.php reindexall:

Product Attributes index was rebuilt successfully
Product Prices index was rebuilt successfully
Catalog URL Rewrites index was rebuilt successfully
Product Flat Data index was rebuilt successfully
Category Flat Data index was rebuilt successfully
Category Products index was rebuilt successfully
Catalog Search Index index was rebuilt successfully
Stock Status index was rebuilt successfully

But after when i go to Magento admin > System > Index Management all Status are still on Processing, and i can't reindex? In Magento admin the date (Updated at) is Sep 5, 2015.. But if i look in /var/locks/ folder the dates from the lock-files are from today Dec 15, 2015.

Somewhere it's stuck. What do i have to do?

2
  • what happens when you reindex via admin? Did you tried removing all var/lock files? If not, please remove and reindex via admin. Dec 15, 2015 at 10:54
  • Yes i tried that. I removed all var/locks files and then i tried to reindex but still i get same error (from the first indexed data): Category Flat Data Index process is working now. Please try run this process later.
    – meez
    Dec 15, 2015 at 11:03

2 Answers 2

0

Try doing it programmatically. This way:

$indexCollection = Mage::getModel('index/process')->getCollection();
    foreach ($indexCollection as $index) {
      $index->reindexAll();
  }
0
0

Check the files owner, it could be that php from command line is running by different user than when running php through Apache or similar. So after reindexing is done via command line, the index lock file is can be only accessed via php cli and when you go to Index Management it cannot perform lock and therefore thinks that reindexing in progress.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.