1

After migrating from a localhost magento instance to a cloud-based server (using IP address, not a domain name yet) using the following approach, I can no longer login ad admin.

  1. Zipped and transferred all files from localhost to cloud server
  2. Imported the mysql database
  3. edited the app/etc/local.xml to connect to the cloud mySQL DB
  4. tweaked core_config_data table in phpmyadmin and replaced several values with 5. new URL (IP address)
  5. cleared var/cache, var/session, var/report, var/log
  6. checked all file and folder permissions.

I am simply returned to the admin console login screen.

I have tried to reset the admin password (via myphpadmin) and even create new admin users without success.

I have read it may be related to the new URL or cookies...however nothing I have tried has worked thus far. Appreciate any input from the Pro's.

Cheers, Damien

1

Without actually knowing the entire setup it's a little tough to diagnose but here are some things to check.

1) Make sure in core_config_data that your web/unsecure/base_url and web/secure/base_url end with a trailing slash after your IP eg: http://1.1.1.1/

2) Make sure your server has sufficient storage. If the disk space is full it cannot properly write sessions

3) Clear the browser website data incase it is trying to use an old session

4) clear var/session and var/cache one more time for good measure

  • 1) Checked and all ok 2) Plenty of space 3) Already tried it 4) Tried that already Any other thoughts? – Damo Dec 15 '15 at 7:39
1

Check your assigned cookie domain and path on the old website. It sounds like some sort of cookie/session issue.

Also, after making any manual changes in core_config_data, if you did not shut off Magento caching before the move, clear the mage--? subfolders in var/cache/ as the config data is cached and won't change until the cache is flushed.

  • Thanks. I checked all fields under the core_config_data table. Seem to be the same as localhost. I also deleted all cached files as needed. Any other ideas? – Damo Dec 15 '15 at 7:35
0

Two things you can try:

  1. Try in different browser. I guess you are using Chrome, try in firefox. Chrome got some issues some time.

  2. Try to change admin password from table admin_user

  • What happens when you try to login in admin? – Akhil Gupta Dec 15 '15 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.