1

I have set previous URL like below in controller

Mage::getSingleton('customer/session')->setBeforeAuthUrl(Mage::helper('core/url')->getCurrentUrl());

After login, it will be redirect to previous url. It's working for Firefox but not working for chrome.

System -> Customer configuration ->Redirect Customer to Account Dashboard after Logging in -> set to NO

1

Use below code in controller to redirect to previous URL:

$this->_redirectReferer()
  • No..It's not working... For firefox it works fine..but for chrome, it redirects to account dashboard.. – Ankita Panchal Dec 14 '15 at 10:57
  • Try this on Private window for both browser. I think some other issue is there. – Akhil Gupta Dec 14 '15 at 12:22
1

May be there is cookie setting issue in your system. Try in incognito mode on chrome. Also check cookie setting at magento admin.

  • No..It's not working... i tried – Ankita Panchal Dec 14 '15 at 10:57
  • Clear var/cache folder and var/session – zed Blackbeard Dec 14 '15 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.