2

After upgarding to 1.9.2.2 the {{block type="cms/block" block_id="home-news-text" template="cms/content.phtml"}} in home page is not displaying the content of the block. I have added the block id in white list but still not appearing. What step am I missing?

enter image description here

8
  • How did you add it? What does the entry look like? DId you flush the cache inbetween? Commented Dec 14, 2015 at 7:42
  • Navigating to System => Permissions => Blocks I added the block name and set the allowed to yes, then I refresh the cache or even diabled the cache but still no changes
    – Zinat
    Commented Dec 14, 2015 at 7:47
  • So, you added "cms/block"? Any errors in your logs? Commented Dec 14, 2015 at 7:48
  • Notice: Undefined variable: block in /mypath/app/code/core/Mage/Core/Model/Email/Template/Filter.php on line 197 which I guess it's not related to this
    – Zinat
    Commented Dec 14, 2015 at 7:50
  • Do any of your other cms blocks work?
    – rob3000
    Commented Dec 14, 2015 at 7:51

1 Answer 1

8

You need to enter the block type="cms/block" instead of the block_id="home-news-text" into the permission form for your blocks to show up.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.