0

I just installed the security patch SUPEE-6788 and the installation was a success from MageReport.com. However, I encountered 404 error on my admin page, yet I can still see the CMS page.

Does anyone know how to fix it?

The problem came up before the patch installation, and I thought the problem will be solved after the patch installation.( And obviously, it's not. ) Before the patch installation, I changed some codes according to this post. http://www.oscprofessionals.com/articles/magento-security-patch-supee-6788-effects-and-testing/

I think the problem occurred after the Change3 to move class files.

I've tried:

Making sure core_store, core_store_group, core_website, and customer_group table ids are set to 0 (as described in this and many other articles - http://www.nude-webdesign.com/fix-for-magento-admin-error-404-page-not-found/)
Cleared the var/cache
According to this post http://alanstorm.com/magentos_many_404_pages, I ran the command: curl -I http://idfr.com
output:
HTTP/1.1 200 OK
Date: Wed, 09 Dec 2015 16:15:17 GMT
Server: Apache/2.4.7 (Ubuntu)
X-Powered-By: PHP/5.5.9-1ubuntu4.14
Set-Cookie: frontend=r1bnk3642gjfgb24vukhu06ma7; expires=Wed, 09-Dec-2015 17:15:17 GMT; Max-Age=3600; path=/; domain=idfr.com; HttpOnly
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: sns_aviva_tpl=sns_aviva; expires=Mon, 28-Nov-2016 16:15:17 GMT; Max-Age=30672000; path=/
Content-Type: text/html; charset=UTF-8

I also ran the command: curl -I http://www.iana.org/domains/idfr
output:
HTTP/1.1 404 NOT FOUND
Vary: Accept-Encoding
Content-Type: text/html; charset=utf-8
Cache-Control: public, max-age=3600
Date: Wed, 09 Dec 2015 16:18:25 GMT
Connection: keep-alive
Server: Apache
X-Cache-Hits: 0
1

Assuming you have SSH access to the server, I would suggest:

  • Cleaning the cache: rm -rf var/cache/*
  • Cleaning the sessions: rm -rf var/session/*
  • Checking the error log on var/log/exception.log
  • Checking the system log on var/log/system.log
  • Checking any error reports generated by magento on var/report

If you're lucky you may find a clue on what's causing Magento to serve you a 404 page (bad routing maybe?).

  • I cleaned the cache and the session. Because of the warning In the system log, I disabled the module but I still got 404 on admin page. [ 2015-12-08T20:53:12+00:00 ERR (3): Warning: SimpleXMLElement::__construct(): ^ in /var/www/idfr/app/code/local/Mgt/Base/Model/Feed.php on line 77 ] – Sonia Dec 10 '15 at 20:07
  • Try disabling all third party modules and removing the cache. If that allows you to access back to the admin panel, then start enabling the modules one by one until you find out what's causing the issue. – J Plana Dec 10 '15 at 20:34
  • Just disabled all the modules, and go to check the site; however, now even the front-end store is giving an error message; "Can't retrieve entity config: core/store_group" – Sonia Dec 10 '15 at 22:00
  • If you disabled the third party modules and you're getting this error, is likely that you have a problem with your database. I would restore the database before doing changes any to the core_ tables and apply the patch without applying any manual queries. – J Plana Dec 10 '15 at 22:42
  • Just restored the database, yet the error log in report is still the same.. – Sonia Dec 11 '15 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.