CRON is working fine according to the Scheduler and all mails were working fine as of monday. Yesterday I noticed that no emails were going out. Is the normal return value from core_email_queue_send_all supposed to be Mage_Core_Model_Email_Quenue?

AoE Scheduler

Nonetheless I can see transactional emails being generated in the database under mage_core_email_queue.

table: mage_core_email_queue

My problem being that they are not sent, either to the recipient or being delivered to the bcc.

Changes I did since monday were installing and uninstalling 2 extensions, Algolia Search and Instant Search+.

I've tried editing cron.php and have added $isShellDisabled = true; beneath
$isShellDisabled = (stripos(PHP_OS, 'win') === false) ? $isShellDisabled : true;
and changed
$cronPath = escapeshellarg(dirname(__FILE__) . '/cron.sh'); to
$cronPath = escapeshellarg(dirname(__FILE__) . '/scheduler_cron.sh');

Any other tricks I should try to get emails functioning again?

Or is my best bet to roll the database back a few days?

When I manually try to fire cron.php from the browser it doesn't show up in the scheduler.

  • What's your 'cron_schedule' table like? Commented Dec 10, 2015 at 11:17
  • Default values are set. 15/20/15/10/60/600/15 and heartbeat is set at */10 * * * *. Mails are set at */1 * * * * Under cron log I can see the following: [10-Dec-2015 11:00:15 UTC] PHP Notice: Trying to get property of non-object in /home/u13g8j8/www/app/code/community/Wyomind/Watchlog/Model/Observer.php on line 112 [10-Dec-2015 11:00:15 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/u13g8j8/www/app/code/community/Wyomind/Watchlog/Model/Observer.php on line 112
    – André
    Commented Dec 10, 2015 at 11:18
  • I'm talking about the MySQL table 'db_name'.'cron_schedule' Commented Dec 10, 2015 at 11:20
  • Sorry, mage_cron_schedule is filled with 125 rows. Some pending and the rest have a status of success. The same I can find by looking at the scheduler under List View
    – André
    Commented Dec 10, 2015 at 11:28
  • Have you tried disabling the Wyomind Watchlog? It's clearly NOT compatible with Magento Commented Dec 10, 2015 at 11:32


Browse other questions tagged or ask your own question.