1

CRON is working fine according to the Scheduler and all mails were working fine as of monday. Yesterday I noticed that no emails were going out. Is the normal return value from core_email_queue_send_all supposed to be Mage_Core_Model_Email_Quenue?

AoE Scheduler

Nonetheless I can see transactional emails being generated in the database under mage_core_email_queue.

table: mage_core_email_queue

My problem being that they are not sent, either to the recipient or being delivered to the bcc.

Changes I did since monday were installing and uninstalling 2 extensions, Algolia Search and Instant Search+.

I've tried editing cron.php and have added $isShellDisabled = true; beneath
$isShellDisabled = (stripos(PHP_OS, 'win') === false) ? $isShellDisabled : true;
and changed
$cronPath = escapeshellarg(dirname(__FILE__) . '/cron.sh'); to
$cronPath = escapeshellarg(dirname(__FILE__) . '/scheduler_cron.sh');

Any other tricks I should try to get emails functioning again?

Or is my best bet to roll the database back a few days?

When I manually try to fire cron.php from the browser it doesn't show up in the scheduler.

closed as off-topic by Qaisar Satti, Sander Mangel, Raphael at Digital Pianism, Amit Bera, Marius Jun 18 '16 at 10:46

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about third-party modules are generally off-topic because the scope of functionality and code are not available. For more information, see this meta post/answer." – Qaisar Satti, Sander Mangel, Raphael at Digital Pianism, Amit Bera, Marius
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What's your 'cron_schedule' table like? – Yiorgos Moschovitis Dec 10 '15 at 11:17
  • Default values are set. 15/20/15/10/60/600/15 and heartbeat is set at */10 * * * *. Mails are set at */1 * * * * Under cron log I can see the following: [10-Dec-2015 11:00:15 UTC] PHP Notice: Trying to get property of non-object in /home/u13g8j8/www/app/code/community/Wyomind/Watchlog/Model/Observer.php on line 112 [10-Dec-2015 11:00:15 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/u13g8j8/www/app/code/community/Wyomind/Watchlog/Model/Observer.php on line 112 – André Dec 10 '15 at 11:18
  • I'm talking about the MySQL table 'db_name'.'cron_schedule' – Yiorgos Moschovitis Dec 10 '15 at 11:20
  • Sorry, mage_cron_schedule is filled with 125 rows. Some pending and the rest have a status of success. The same I can find by looking at the scheduler under List View – André Dec 10 '15 at 11:28
  • Have you tried disabling the Wyomind Watchlog? It's clearly NOT compatible with Magento 1.9.2.2 – Yiorgos Moschovitis Dec 10 '15 at 11:32