4

I'm having problems with showing the countries in my magento website. When you want to give in you're billing address it's required to give in your country. The problem is that the countries are empty :

enter image description here

As you can see the select list is empty. But in my backend I have the following allowed countries:

enter image description here

That's my default config and I use it for the website, nl and fr store:

enter image description here

In my config in my database you can also see it:

INSERT INTO `pp_core_config_data` (`config_id`, `scope`, `scope_id`, `path`, `value`)
VALUES
    (14, 'default', 0, 'general/country/allow', 'AF,AX,AL,DZ,AS,VI,UM,AD,AO,AI,AQ,AG,AR,AM,AW,AU,AZ,BS,BH,BD,BB,BE,BZ,BJ,BM,BT,BO,BA,BW,BV,BR,IO,VG,BN,BG,BF,BI,KH,CA,KY,CF,CL,CN,CX,CC,CO,KM,CG,CD,CK,CR,CU,CY,DK,DJ,DM,DO,DE,EC,EG,SV,GQ,ER,EE,ET,FO,FK,FJ,PH,FI,FR,GF,PF,TF,GA,GM,GE,GH,GI,GD,GR,GL,GP,GU,GT,GG,GN,GW,GY,HT,HM,HN,HU,HK,IS,IE,IN,ID,IQ,IR,IM,IL,IT,CI,JM,JP,YE,JE,JO,CV,CM,KZ,KE,KG,KI,KW,HR,LA,LS,LV,LB,LR,LY,LI,LT,LU,MO,MK,MG,MW,MV,MY,ML,MT,MA,MH,MQ,MR,MU,YT,MX,FM,MD,MC,MN,ME,MS,MZ,MM,NA,NR,NL,AN,NP,NI,NC,NZ,NE,NG,NU,KP,MP,NO,NF,UG,UA,UZ,OM,TL,AT,PK,PW,PS,PA,PG,PY,PE,PN,PL,PT,PR,QA,RO,RU,RW,RE,BL,KN,LC,PM,VC,SB,WS,SM,ST,SA,SN,RS,SC,SL,SG,SH,MF,SI,SK,SD,SO,ES,LK,SR,SJ,SZ,SY,TJ,TW,TZ,TH,TG,TK,TO,TT,TD,CZ,TN,TR,TM,TC,TV,UY,VU,VA,VE,GB,AE,US,VN,WF,EH,BY,ZM,ZW,ZA,GS,KR,SE,CH');

When I debug it with xDebug I can see the config variable with an _xml property:

enter image description here

The path of the config value is general/country/allow and the full path (for specific store) is stores/nl/general/country/allow.

But when I check stores/general/ there's only locale and NOT country. What could be the reason for this? I'm really stuck with this and I have no clue what's causing this ... .

I'm using Magento ver. 1.7.0.2 . (Also maybe good to know: this worked on another server, but when we cloned it to our server it doesn't work anymore ..)

  • Just to make it clear. You don't have overrides of this config in Website Scope (Pharmaprofit Website) and/or in Store View Scopes (Francais/Nederlands) – Yiorgos Moschovitis Dec 11 '15 at 10:02
  • No, I always use the default config. – nielsv Dec 11 '15 at 12:59
  • 1
    I've found the answer in this SO topic. – nielsv Dec 12 '15 at 11:47
  • 1
    Then please add the solution as an answer and accept it. – Fabian Schmengler Dec 14 '15 at 8:53
2

Please goto Current Configuration Scope: Select Default Store View

Now in General - > Countries Options Select

Default Country -> <select your country>
Allow Country   -> <select all>

Select Both CheckBox right side

[X] Use Website [STORE VIEW]

and SAVE CONFIG it you will get you default country selected and you can choose another country from the list.

enter image description here

| improve this answer | |
1

Just clean core_config_data table for that path something like: delete from core_config_data where path = 'general/country/allow'; then obviously, flush cache. If problem persists you may take a look on the template/block and debug that value.

Are you using some extension there, if so, try to deactivate it?

There is some Javascript involve in this select, so take a look at the browser console too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.