0

I tried to install magento 2 and it hangs while loading module Module 'Magento_CustomerSampleData':

Here is my Environment:

Ubuntu 14.04 Ngix MySQL I have attached a screen for reference.

enter image description here

3

Try to increase value of max_execution_time in PHP to 1800 (30 minutes).

1

Installing sample data takes time.

If installing sample data blocks your installation process, you can install Magento without sample data and then install sample data separately using this manual http://devdocs.magento.com/guides/v2.0/install-gde/install/sample-data-after-magento.html

Also try to increase value of max_execution_time.

This link can be also helpful: Sample data for Magento 2 - PHP memory problem while installing from Composer

UPD. http://devdocs.magento.com/guides/v2.0/install-gde/trouble/php/tshoot_70pct.html

1

if you are using Apache+PHP-FPM like myself this might work for you:

<Proxy "fcgi://127.0.0.1:9000/opt/rh/httpd24/root/var/www/m2">
    ProxySet min=0
    ProxySet timeout=1800
</Proxy>

<LocationMatch "^(.*\.php).*$">
    ProxyPass fcgi://127.0.0.1:9000/opt/rh/httpd24/root/var/www/m2
</LocationMatch>

The reason it stopped for me was that apache stopped talking to php-fpm proxy.

here is the error I got in my apache log:

[proxy_fcgi:error] [pid 7698] (70007)The timeout specified has expired: [client 178.79.164.65:36691] AH01075: Error dispatching request to :, referer: http://54.153.44.88/setup/

I fixed the problem my setting proxy timeout as shown above.

0

Try to resume your sample data entry again by using teminal -

be in your root folder of installation

root@sys:/var/www/html/magento2#

use below command -

php -f bin/magento sampledata:deploy

  • No Luck with command php -f bin/magento sampledata:deploy. Throws an error ` [Composer\Downloader\TransportException] The 'repo.magento.com/packages.json' URL required authentication. You must be using the interactive console to authenticate` – Manjunath Reddy Dec 28 '15 at 8:09
0

This may also be caused by a missing .htaccess file. (In my case, the . Systemfiles were missed when copying the data)

After adding the .htaccess the installation worked perfectly

0

Are you in developer mode?

1 first get the M2 without sample data and unzip it hosting.

2 get in developer mode

3 create the database

4 change folders and files permissions.

5 create a folder and copy all the files right now in the public folder in there (is like a emergency folder)

6 unzip the designs and components you plan to use.

7 install.

it should work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.