3

Magmi has Stopped Working in Magento 2. till Magento 1.9.2 it was working fine, as there is no local.xml file in magento 2. we tried by creating that file but when magmi run give this error

Blockquote : error 1:SQLSTATE[42S02]: Base table or view not found: 1146 Table 'magento.core_store' doesn't exist -

Any suggests to import bulk product in magento? as Magmi was great tool to import Bulk data.

2
  • You will need to get a version of Magmi that supports Magento 2.0. Same goes for themes, modules, etc. If they're not available, then you will have to wait till they are or do without. Blindly going out and doing a Magento upgrade has always been fraught with this danger, moreso with the Magento 2.0 MIGRATION as 2.0 is structurally so different that a mere upgrade isn't possible, It requires complete code rewrites on modules and utilities. – Fiasco Labs Dec 5 '15 at 20:06
  • Here is fresh fork with merge previous attempts github.com/macopedia/magmi-git – FireBear Jun 6 '17 at 14:52
5

Magmi is only supported right now for the Magento 1.x platform.

Looking at their github, there are a few active tickets open like:

Magmi + Magento 2.0

Extensions need to be redeveloped from Magento 1 to Magento 2.

3

Magmi is not compatible with Magento 2 at this time (Dec 2015). It probably will not be compatible for some time. You should find other means to accomplish what you're trying to do.

Not the answer you're looking for? Browse other questions tagged or ask your own question.