8

I got this error while installing Magento2

[ERROR] exception 'LogicException' with message 'Unknown module in the requested list: 'Magento_BundleSampleData'' in setup\src\Magento\Setup\Model\Installer.php:403
Stack trace:
#0 setup\src\Magento\Setup\Model\Installer.php(364): Magento\Setup\Model\Installer->readListOfModules(Array, Array, 'enable_modules') 
#1 setup\src\Magento\Setup\Model\Installer.php(323): Magento\Setup\Model\Installer->createModulesConfig(Array) 
#2 setup\src\Magento\Setup\Controller\Install.php(97): Magento\Setup\Model\Installer->install(Array) 
#3 vendor\zendframework\zend-mvc\src\Controller\AbstractActionController.php(82): Magento\Setup\Controller\Install->startAction() 
#4 [internal function]: Zend\Mvc\Controller\AbstractActionController->onDispatch(Object(Zend\Mvc\MvcEvent)) 
#5 vendor\zendframework\zend-eventmanager\src\EventManager.php(444): call_user_func(Array, Object(Zend\Mvc\MvcEvent)) 
#6 vendor\zendframework\zend-eventmanager\src\EventManager.php(205): Zend\EventManager\EventManager->triggerListeners('dispatch', Object(Zend\Mvc\MvcEvent), Object(Closure)) 
#7 vendor\zendframework\zend-mvc\src\Controller\AbstractController.php(118): Zend\EventManager\EventManager->trigger('dispatch', Object(Zend\Mvc\MvcEvent), Object(Closure)) 
#8 vendor\zendframework\zend-mvc\src\DispatchListener.php(93): Zend\Mvc\Controller\AbstractController->dispatch(Object(Zend\Http\PhpEnvironment\Request), Object(Zend\Http\PhpEnvironment\Response)) 
#9 [internal function]: Zend\Mvc\DispatchListener->onDispatch(Object(Zend\Mvc\MvcEvent)) 
#10 vendor\zendframework\zend-eventmanager\src\EventManager.php(444): call_user_func(Array, Object(Zend\Mvc\MvcEvent)) 
#11 vendor\zendframework\zend-eventmanager\src\EventManager.php(205): Zend\EventManager\EventManager->triggerListeners('dispatch', Object(Zend\Mvc\MvcEvent), Object(Closure)) 
#12 vendor\zendframework\zend-mvc\src\Application.php(314): Zend\EventManager\EventManager->trigger('dispatch', Object(Zend\Mvc\MvcEvent), Object(Closure)) 
#13 setup\index.php(31): Zend\Mvc\Application->run() 
#14 {main}

Also see this screenshot:

enter image description here

Please help me!

  • What is Magento2 version you install ? – Thao Pham Dec 4 '15 at 3:34
  • 2.0, no samples – Jeffery Dec 4 '15 at 3:36
  • Are you download it from Github ? – Thao Pham Dec 4 '15 at 3:37
  • 1
    @Jeffery did you have a previous installation? is your database clean? – Maddy Jan 20 '16 at 15:31
  • 3
    Also, clean browser cache. – Maddy Jan 20 '16 at 15:52
15

Most of the time these type of errors come when you try to install magento2 previously and it was failed due to some reason.

and you have started your installation process again after removing all of the previous installed files and removed old database entry.

So, to overcome this issue, before starting your installation process, just remove your browser's cookie.

Enjoy :)

  • 1
    You're the hero of the day. Who stores that in a cookie...?!? Thanks! – Mike Oct 11 '18 at 15:31
  • Magento is absolutely pathetic sometimes, seriously! – F3L1X79 May 24 at 7:55
4

Clear the cache of your browser. It's work for me.

2

From Customize Your Store step in Advanced Modules Configurations, Uncheck 'Magento_SampleBundleData' and continue on to install. I was stuck with the same error so moved back to the step and unchecked the module.

Also check that you've your browser cache cleaned. This was on version (magento ce)2.0.2

Hope it helps.

2

Try to restart the server, mysql and check,

and remove the browser cookies to

Refer this link : https://devdocs.magento.com/guides/v2.0/install-gde/trouble/tshoot_bundlesampledata.html

0

I think you should restart your mysql in this case.

sudo service mysql restart
 * Stopping MySQL Community Server 5.6.30
....
 * MySQL Community Server 5.6.30 is stopped
 * Re-starting MySQL Community Server 5.6.30
......
 * MySQL Community Server 5.6.30 is started

if it still does not work fine, please restart apache2 also:

sudo service apache2 restart
0

Clear your browser cache and cookies OR just use some other browser. I was facing the same issue. I just used Mozilla Firefox instead of Google Chrome and all fixed.

0

I faced the same issue and after that I tried to install with Firefox which worked perfectly and no need to do any thing.

 Try With Firefox Browser.
  • Seemed a bit weird to me, but it worked, Thank you. – Pedram marandi Jan 2 at 14:57
  • @Seemed you are welcome. – Manish Goswami Jan 3 at 5:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.