1

I have created the custom admin module working fine.

but when my layout file(mca.xml) put on adminhtml->default->default->layout->mca.xml

it's working fine.

enter image description here

but when I put file into my package adminhtml->default->Course->layout->mca.xml it's not working? showing empty page.

enter image description here

can anyone tell me where I went wrong?

thanks in advance.

3

Have you set adminhtml/default/Course/layout to be your default adminhtml theme?

To do so you can specify the theme in your module's config.xml.

<stores>
    <admin>
        <design>
            <package>
                <name>default</name>
            </package>
            <theme>
                <default>Course</default>
            </theme>
        </design>
    </admin>
</stores>
  • hi adam, where it is? – Manoj Kumar Oct 10 '13 at 13:37
  • 1
    Actually, without some coding this is not possible, so if you didn't change the core templating code I'm pretty sure you can only put it in adminhtml/default/default/layout – Sander Mangel Oct 10 '13 at 13:39
  • I set the Configuration->Design->Package->Current Package Name=Course. is there another option for admin panel – Manoj Kumar Oct 10 '13 at 13:41
  • That's just for frontend, mot adminhtml. There is no easy way of changing the template directory of the adminhtml – Sander Mangel Oct 10 '13 at 13:44
  • 1
    @AdamPaterson,actually I put it in default under my package, now I remove default folder in my package now working fine. thank you :) – Manoj Kumar Oct 10 '13 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.