4

Good Afternoon guys,

We're currently experiencing an intermittent problem where when a user selects Paypal (Standard) as a payment option, they're being redirected to an empty cart rather than the Paypal website. These seems to only happen on IE Browsers. The strange thing is we've edited the site a couple of times and seemingly fixed the issue, only for it to return a day or so later.

Setup details are:

  • Mage 1.7.0.2
  • Onestepcheckout

The items we've edited which seemed to have fixed the issue are all related to X-UA-Compatible settings.


As per the comments, I'm going to run through the things we've tried in an effort to fix the issue.

  • Using X-UA-Compatible to change which version of IE Standards are used, weighted to try and use IE8 (both header and .htaccess based).
  • Debugging the /onestepcheckout/index/index/ controller (which is used as the action of the checkout form) and this shows that as soon as the process enters this step the cart is empty.
  • Debugging shows that the system goes straight into the /onestepcheckout/index/index/ controller also (using Charles Debugging Proxy), and makes no attempt to redirect to PayPal.

The strangest thing is that, after changing the IE Standards being used, the site will work for a short while (replicated on numerous machines) but then revert back to not working after a few hours?


Your help, as always, is massively appreciated,

  • Sounds like you are loosing sessions. If you are logged in at checkout, do you also get logged out when you get sent To the empty cart? – ProxiBlue Oct 10 '13 at 14:07
  • Hi ProxiBlue - thanks for the reply. We thought similar, but people aren't being logged out at the same time. One thought we did have is that when the customer is redirected to PayPal, their cart is emptied anyway, therefore it may be that the redirect fails, however as soon as the controller for onestepcheckout is ran, the cart is empty. – thebluefox Oct 10 '13 at 16:35
  • Well, that is a good thing. Session issues are really difficult to figure out. Could you maybe update your question and list what you have tried? It will help not waste time by suggestinbg whats been done / tried already – ProxiBlue Oct 11 '13 at 1:34
  • Done! If theres anything else that can help, let me know. – thebluefox Oct 14 '13 at 8:29
  • 1
    NB: we've noticed some of the third-party one-step-checkout vendors completely hose PayPal functionality. We are working with them to update their extensions, so you may want to check if there is a new version of your extension. – benmarks Feb 15 '15 at 17:29
2

In the end, this was an issue with a 3rd party payment extension, as @benmarks has just mentioned.

After disabling the frontend sections of Ebizmarts SagePay Pro extension (we had to keep the backend stuff for historic orders/transactions) the problems stopped. I never 100% tracked the issue down to a specific line of code, but I did get it to a point where it was replicable, and therefore could prove that this extension was the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.