2

I just installed Magento 2, it shown the success page result however the admin folder is not found.

Also the main page does not seem to be ok, seems like css is not in place, there is no menu... just their text and images.

Didn't find any error message. Any idea?

Thanks!

  • 1
    What web server are you using? Apache of Nginx? Also, do you havve localhost as your hostname? – Maddy Jan 15 '16 at 15:35
0

For admin, please check the /app/etc/env.php file for backend=>frontname for example admin_mm0iwi. Then navigate to <your host>/admin_mm0iwi. If this is not working, please check if you have mod rewrite turned on in apache. Also, it is recommended to NOT have localhost as your hostname, since some browsers have issues with cookies.

For no css, please run the bin/magento setup:static-content:deploy on your console.

  • How to turned on the mod rewrite on apache?. – MrTo-Kane May 10 '16 at 7:18
  • I found: > nano /etc/httpd/conf/httpd.conf ++find >>follow (AllowOverride none) ++and change it >> (AllowOverride All) – MrTo-Kane May 10 '16 at 7:26
0

I was also faced with this issue and managed to solve it with the help of this site

Here's where it comes down to:

First: enable mod_rewrite:

  1. open terminal
  2. enable mod_rewrite
  3. restart apache2

sudo a2enmod rewrite

sudo systemctl restart apache2

Secondly: adjust your .conf file:

  1. locate your .conf file
  2. add the <Directory ...> code
  3. restart apache2

ls /etc/apache2/sites-available

sudo nano /etc/apache2/sites-available/000-default.conf

Add this code below the tag:

<Directory /var/www/html>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Require all granted
</Directory>

sudo systemctl restart apache2

And now you should be able to surf to your own admin page

Note: you'll probably use the 000-default.conf, unless you have set up a different VirtualHost. In that case you need to change the 000-default.conf with your own VirtualHost.conf file and change the /var/www/html to point to your own public_html directory.

Note2: use ctrl-o in nano to save a file and ctrl-x to close it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.