1

Backend goes horribly slow. Page loads of 10+ seconds.

We have a large Magento site with over 56k orders, 1.9k products and 2 store views.

Tried enabling PHP slowlog, and I couldn't find any relevant slow queries. Same goes for slow queries on the DB server.

Using Chrome developer tools I got a clue on what's going on:

Order and Product Grid takes 10+ seconds time to first byte (TTFB).

After enabling the Magento native Varien Profiler I got some interesting insights:

enter image description here

Taking a deep look at the webserver and database performance, I can't see anything wrong with CPU/Memory/Disk usage.

Site setup:

  • Magento Community Edition 1.9
  • We have a Load Balancer with a thin layer of caching for static objects.
  • One webserver running Nginx + Php-fpm + Redis, on a Cloud Server with 8 CPUs + 30GB RAM + 300 GB SSD storage.
  • One database server running MariaDB , on a Cloud Server with 8 CPUs + 8GB RAM + 160 GB SSD storage.

Caching setup:

  • Database caching is enabled.
  • Nginx is configured to send cache headers for static objects.
  • PHP version 5.4 is configured to use Zend OpCache.
  • Magento is using default native cache + Amasty Full Page Cache.
  • Magento backend is set to use Redis for session management..
  • Load Balancer does cache static content.

The frontend goes lightning fast, and the second page load (serving static content from user browser cache) is even faster.

SOLUTION

BL Custom Grid module was slowing the order and product grids to 10-19 seconds. Disabling the module solved the issue.

Thank you to everyone who helped!

  • The Varien Profiler line you're pointing to is pretty high in the call stack -- i.e. it's closer to profiles the time for the entire request. Look for larger numbers lower on that list to help zero in on this. – Alan Storm Dec 2 '15 at 19:36
  • Hi Alan, thanks for the reply. I managed to identify a module that was causing the bottleneck: BL Custom Grids magentocommerce.com/magento-connect/… – J Plana Dec 2 '15 at 22:36
1

I had this problem once. Turned out one of the installed extensions tried to "phone home" on each admin-page-load to a server that was no longer maintained - so the request this server had to time out before the actual admin page was rendered.

The extension I used back then was Robogento_RichSnippets.

I found this error by disabling all extensions in codepool "local" in the local.xml file, and suddenly the backend was fast again. After that, I re-enabled the extensions one for one.

  • Aitoc extensions also tend to do this – Andrew Kett Dec 2 '15 at 19:25
  • I tried disabling the local extensions using the disable_local_modules node, and didn't get any better. – J Plana Dec 2 '15 at 19:27
  • We use aitoc quantity manager to manage multi store inventory. I will have a look into that. Thank you – J Plana Dec 2 '15 at 19:28
  • It doesn't need to be a local module, can also be in community pool. I don't think there's such a nice solution to disable them all with one command, though – simonthesorcerer Dec 2 '15 at 19:29
  • I'm voting your answer as a solution, because between you and Alan Storm pointed me out in the right direction. Thanks everyone for your help! – J Plana Dec 2 '15 at 22:38
0

Sounds like you have a memory leak somewhere. What is your category list page like? Are you calling attributes on that page?

  • Hi Nam, When you say category list page, you mean Catalog > Manage categories? – J Plana Dec 2 '15 at 19:09
  • Sorry. I got confused. In the backend of magento, do you have a lot of bundled products? Do you have products with a ton of attributes and categories? For example, could one product be under 20+ categories? – Nam Bui Dec 2 '15 at 19:12
  • We don't have bundle products, just simples and configurables. We have custom attributes on every product (around 10 custom attributes) and normally the product belong to 1-3 categories – J Plana Dec 2 '15 at 19:15
  • What do you mean by "Magento backend is set to use Redis." Is this the sessions or the full page cache? – Nam Bui Dec 2 '15 at 19:17
  • How have you configured opcache? Is it just a default, blanket install or have you tweaked it? – Nam Bui Dec 2 '15 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.