3

I installed Magento 2 on a new fresh installed VPS, running Debian 8. Magento is installed and I can seem to be working OK, but I cannot see any images on the front end and when I look in the catalog.

I'm running Apache 2.4, PHP 5.6 and MySQL 5.6

  • you need to check if images actually on the server... – MagenX Dec 3 '15 at 9:44
  • I followed the path from within chrome inspect elements and the images are there, the permissions are correct too, but stil the images do not show up. The Luma Logo, css etc all show in the front end and all the css and images on the backup show too. It's just the images in the front end that don't show. thanks – Joe Dec 4 '15 at 11:39
  • Follow steps according to below to show images magento.stackexchange.com/a/92485/4342 – Neeraj Garg Mar 10 '16 at 11:50
  • You can find the answer of the problem here: magento.stackexchange.com/a/97230/34408 – Tapas Ranjan Jun 27 '17 at 7:50
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Piyush May 30 '19 at 7:14
2

Try to run these commands on the root of the project:

php bin/magento cache:flush
php bin/magento cache:clean
php bin/magento setup:static-content:deploy
php bin/magento indexer:reindex
chmod 777 -R .
| improve this answer | |
  • 1
    Note that the last line of this answer sets up very unsafe permissions. You should NOT be setting permissions to 777 on a production environment. – jsims281 Aug 20 '18 at 7:29
1

Your Static Contents are most likely out of date. You can regenerate your static contents with this command on your server from your Magento 2 root folder. Note that you may or may not need to delete files from pub/static/frontend

php bin/magento setup:static-content:deploy <locale>
| improve this answer | |
0

Yes, it will happen if you use the Windows platform instead of Linux.

Because in Magento 2 recent release, they have introduced the Symlink option (Like shortcut of an existing file) to copy from code directory to pub directory.

Unfortunately, the Windows platform needs special permission to create symlink files. So you need to stop your server and your command prompt terminal then we need to start the server and terminal with the administrator access.

Then simply delete "adminhtml" and "frontend" folders from "pub/static" directory. Then do setup upgrade using

php bin\magento setup:upgrade

Flush the cache once using

php bin\magento cache:flush

I hope the problem is resolved now. If it works kindly give me Thumbs up.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.