0

As per the update in magento for security patch SUPEE6788 as mentioned in [link][1]

[1]: http://magento.com/security/patches/supee-6788-technical-details i just change my config.xml from pervious code

<admin>
        <routers>
            <shipping>
                <use>admin</use>
                <args>
                    <module>Test_Shipping</module>
                    <frontName>shipping</frontName>
                </args>
            </shipping>
        </routers>
    </admin>

to

<admin>
        <routers>
            <adminhtml>
                <args>
                    <modules>
                        <test_shipping after="Mage_Adminhtml">TestShipping_Adminhtml</test_shipping>
                    </modules>
                </args>
            </adminhtml>
        </routers>
    </admin>

but it did not work for me can anyone has solution for this issue.

  • 1
    Check thread magento.stackexchange.com/questions/88045/… – Anshu Mishra Dec 1 '15 at 11:45
  • You will also need to add "What is not working". Are you seeing some blank pages or 404 pages in admin or in frontend. What menu items, if any, do you have in admin and how you are generating them. – Prateek Dec 1 '15 at 13:21
  • yes it shows 404 pages not found – Paras Arora Dec 1 '15 at 13:28
3

Changing config.xml to apply security patch SUPEE6788 sometimes is not enough to get a working admin module especially with a custom admin router.

Try to check those points:

  • Under controllers folder you have an Adminhtml folder
  • controllers names are named correctly and action method is called successfully
  • admin layout folder contain the right action handler /app/design/adminhtml/default/default/layout/your_modul.xml which call the right bloc name
  • acl node is defined correctly in adminhtml.xml or config.xml
  • _isAllowed() method is not overrided and if it's the case try to check $resource parameter of isAllowed() method
  • clean the cache, disable compilation and check the result
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.