0

I am having an issue because I cannot create a new user. The admin panel is telling me the "Group" is required but there is no drop down which I could use to select a group.

Is there any modification to do in the code to get this appearing? How should I proceed to find the cause of this problem.

enter image description here

Thank for the help in advance.

  • Customer group comes in Magento by default. You might have installed some extension that is stopping it from appearing. – Prateek Nov 27 '15 at 12:52
  • Hmm. Not really but created some. If you have any idea how to start debugging that would help me a lot. – user2360915 Nov 27 '15 at 13:33
  • I'd suggest try disabling them one by one and see, disabling which shows the customer group back in the form. I hope you have not modified any core files! – Prateek Nov 27 '15 at 13:36
  • Nope we didnt. I tried to disable those 2 modules that relates to customer, but still the group wont show up. If you know how this is managed internally, maybe we can add debug logs to see what is going on. – user2360915 Nov 27 '15 at 14:40
  • You can enable hints in admin via this link : classyllama.com/blog/enable-templateblock-hints-in-admin-panel. If customer form is coming from default locations, then you might have setup used_in_forms of customer_group somewhere incorrect, otherwise it will show up the templates over-riding default ones. – Prateek Nov 27 '15 at 14:52
0

I found my issue. The files under adminhtml/base/default/template/customer/edit/tab/ for some reason disappeared. Copying the files from Magento install package in this directory fixed my issue.

Thanks to Prateek who guided me on this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.