1

I am facing error in magento/admin catalog > manage product> and product.

when I am trying to open Product its giving error :

There has been an error processing your request
Exception printing is disabled by default for security reasons.
Error log record number: 1102395163076

I am seeing this error only in Catalog >products.

I checked error report in var>report, this is what it says:

    a:5:{i:0;s:110:"Source model "temando/entity_attribute_source_packaging_mode" not found for attribute "temando_packaging_mode"";i:1;s:3814:"#0 /home/cluster-sites/4157/e/eponaforge.com/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(387): Mage::exception('Mage_Eav', 'Source model "t...')
#1 public_html/app/code/core/Mage/Adminhtml/Block/Widget/Form.php(201): Mage_Eav_Model_Entity_Attribute_Abstract->getSource()
#2 public_html/app/code/core/Mage/Adminhtml/Block/Catalog/Product/Edit/Tab/Attributes.php(70): Mage_Adminhtml_Block_Widget_Form->_setFieldset(Array, Object(Varien_Data_Form_Element_Fieldset), Array)
#3 /public_html/app/code/core/Mage/Adminhtml/Block/Widget/Form.php(144): Mage_Adminhtml_Block_Catalog_Product_Edit_Tab_Attributes->_prepareForm()
#4 /public_html/app/code/core/Mage/Core/Block/Abstract.php(918): Mage_Adminhtml_Block_Widget_Form->_beforeToHtml()
#5 /public_html/app/code/core/Mage/Adminhtml/Block/Catalog/Product/Edit/Tabs.php(79): Mage_Core_Block_Abstract->toHtml()
#6 /public_html/app/code/core/Mage/Core/Block/Abstract.php(293): Mage_Adminhtml_Block_Catalog_Product_Edit_Tabs->_prepareLayout()
#7 /public_html/app/code/core/Mage/Core/Model/Layout.php(456): Mage_Core_Block_Abstract->setLayout(Object(Mage_Core_Model_Layout))
#8 /public_html/app/code/core/Mage/Core/Model/Layout.php(472): Mage_Core_Model_Layout->createBlock('adminhtml/catal...', 'product_tabs')
#9 /public_html/app/code/core/Mage/Core/Model/Layout.php(239): Mage_Core_Model_Layout->addBlock('adminhtml/catal...', 'product_tabs')
#10 /public_html/app/code/core/Mage/Core/Model/Layout.php(205): Mage_Core_Model_Layout->_generateBlock(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))
#11 /public_html/app/code/core/Mage/Core/Model/Layout.php(210): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#12 /public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(344): Mage_Core_Model_Layout->generateBlocks()
#13 /public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(269): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()
#14 /public_html/app/code/core/Mage/Adminhtml/Controller/Action.php(275): Mage_Core_Controller_Varien_Action->loadLayout(Array, true, true)
#15 /public_html/app/code/core/Mage/Adminhtml/controllers/Catalog/ProductController.php(207): Mage_Adminhtml_Controller_Action->loadLayout(Array)
#16 /public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_Catalog_ProductController->newAction()
#17 /public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('new')
#18 /public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#19 /public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#20 /public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#21 /public_html/index.php(87): Mage::run('', 'store')
#22 {main}";s:3:"url";s:92:"/index.php/admin/catalog_product/new/set/4/type/simple/key/4beccee60930382af9537cd1010c4f7a/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}
  • Did you edited your database ? – Vishwas Bhatnagar Nov 27 '15 at 10:06
  • no.. i did not edit anything in database – Nisha Sharma Nov 27 '15 at 10:06
1

You might have missing class file

Namespace_Temando_Entity_Attribute_Source_Packaging_Mod

Check if Mod.php exist in your Temando module folder.

This file is used by the attribute temando_packaging_mode and it is not able to find in your module.

  • i already removed temando extension. so this error coming bcz of that extension... i removed the extension and cleared the cache.... – Nisha Sharma Nov 27 '15 at 10:21
  • Ok than you need to remove temando_packaging_mode attribute also – Akhilesh Patel Nov 27 '15 at 10:21
  • You can delete it from Catalog -> Attribute -> Manage Attributes section in admin – Akhilesh Patel Nov 27 '15 at 10:22
  • unable to delete the temando attributes... its not deleting – Nisha Sharma Nov 27 '15 at 10:34
  • what error it is showing? you can delete it from eav_attribute table from database as well – Akhilesh Patel Nov 27 '15 at 10:39
1

So this happens because there is an attribute with the source model temando/entity_attribute_source_packaging_mode. When you remove this module it does not remove the attributes created by the module.

The way I normally do this is have a project specific setup module Project_Setup. This module is simply a bunch of set-up scripts for adding/removing attributes etc. What you can do is make a module and a setup script that simply removes the attribute temando_packaging_mode and anything else that has been added by the other module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.