6

I installed Magento 2 on Ubuntu 14.04, and tried to examine whether anything I need to update in Magento system.

I enter "Web Setup Wizard" from admin panel, but it shows the error message at the first step.

"Sorry, we can't take that action right now."

I have tried to find the solution in the official document, but nothing is found.

enter image description here

  • Thank everyone for answering my question. At the last, I still can't find out the solution. So I re-install my VM OS and Magento2. Therefore, these new answers below I can't test them working or not. If someone get solution from this post, please let the user (who supplies the answer) know. Thanks again. – Sam May 19 '16 at 6:05
4

Just had the same problem with my install. Resolved it by entering the Public / Private Access Keys (in the Web Setup Wizard's System Config, 'Magento Marketplace').

You can get these when you log into your account on magento.com - Click on 'Connect' tab at top, then click on 'Developers' button to reveal 'Secure Keys' link. Click on it to manage / create keys.

2

The error message comes from setup/view/magento/setup/select-version.phtml and is displayed if the value of the variable upgradeProcessed is false.
The variable is set in setup/pub/magento/setup/select-version.js.
Initially this is set to false and it is set to true if there is a success response from the url index.php/select-version/systemPackage.
This url is mapped to setup/src/Magento/Setup/Controller/SelectVersion.php and systemPackageAction.
So I guess something goes wrong in here.
I have no idea what, but this is a great place to start debugging.

  • I got the reponse - {error: "System package not found", responseType: "error"} from success calback of $http.get('index.php/select-version/systemPackage', {'responseType': 'json'}) – Sam Nov 27 '15 at 7:25
  • the error message comes from here: github.com/magento/magento2/blob/develop/setup/src/Magento/… – Marius Nov 27 '15 at 7:30
  • It seems that my $systemPackageInfo value is false, but I still don't know why... By the way, my $systemPackages value is [magento/product-community-edition] – Sam Nov 27 '15 at 8:02
0

Most of the time, the problem is caused by the fact that you're not authenticated.

But sometimes, it's caused by the fact that you installed Magento 2 by cloning the GitHub repository.

In that case, you cannot use the Web Setup Wizard and have to run the following commands:

git pull origin
composer update

More details can be found here: http://devdocs.magento.com/guides/v2.0/comp-mgr/trouble/cman/were-sorry.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.