-1

I'm experiencing a rather strange issue with the Magento Front-end Search on my webstore.

I have two products called 'Terry White Chemists Aqueous Cream' and 'Terry White Cough Syrup'.

Both products have the same configuration in regards to inventory. Status is set to Enabled, visibility is set to Catalog, Search, Stock is set to In Stock with a positive stock level, the products have been assigned to a category (of which other products in this category are appearing in the search), and both are simple products with no related or child products.

For some reason, when searching 'Terry White', the search returns 0 results. However, when searching for 'Aqueous Cream' or 'Cough Syrup', these products are displayed in the search results.

I have also checked and found that 'Terry White' is a search term under 'Catalog > Search Terms'.

So far I have tried the following methods to get these products to appear:

  1. Flushed and refreshed Magento Cache
  2. Reindexed entire webstore
  3. Double checked all product configuration options
  4. Set all options to 'Disabled', 'Out of stock' etc, saved and then set back to 'Enabled' and 'In Stock' etc
  5. Deleted 'Terry White' from 'Search Terms'

So it seems that Magento has an issue returning results from a particular set of words, specifically 'Terry White' in the case of my store.

Has anybody experienced an issue of this nature?

It is also worth noting that in 'System > Configuration > Catalog Search', I have set the following options:

  • Minimum Query Length = 1
  • Maximum Query Length = 128
  • Maximum Query Words Count = 10
  • Search Type = Fulltext
  • Apply Layered Nav if Results are Less than = 2000

I've tried using 'Like', 'Fulltext', and 'Combine'. However, the issue still remains.

I'm currently baffled as to why the products are not showing up with this search term, given that it is both in the product title and URL.

Any help would be greatly appreciated.

0

Please go through Catalog->Attributes->Manage Attributes-> Search attribute code "name"

Inside "Frontend Properties" set Use in Quick Search "Yes"

Hope this help.

  • Unfortunately this setting is already set to "Yes" – Rob Nov 27 '15 at 5:45
  • Then this is default magento properties & It should work. Check if any third party extension is overriding the code. or check in private window once. – Akhil Gupta Nov 27 '15 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.