1

A client's web hosting support have created a development site for me @ dev.example.com.

When I try to load http://dev.example.com/admin, I am redirected to https://dev.example.com/index.php/admin/, and receive the error:

The requested URL /index.php/admin/ was not found on this server.

mod_rewrite is enabled, and the .htaccess file is the same as the production site @ example.com.

web/unsecure/base_url & web/secure/base_url are set okay in the core_config_data database table.

How do I fix this please? Thanks.

  • Did you change admin url?? – Magento 2 Nov 26 '15 at 12:48
  • @Kothari: thanks for your assistance. I didn't change it myself. Where would I check to see if it has been changed? – Steve Nov 26 '15 at 12:55
  • check app->etc->local.xml. Share your url – Magento 2 Nov 26 '15 at 12:56
  • There is no file there, only a pointer, which points to another local.xml elsewhere I believe, which contains: <admin> <routers> <adminhtml> <args> <frontName><![CDATA[admin]]></frontName> </args> </adminhtml> </routers> </admin> – Steve Nov 26 '15 at 12:58
  • Ok share your url – Magento 2 Nov 26 '15 at 12:59
0

Web hosting support told me:

the /admin site was automatically forwarding to HTTPS. This must have been set in the app itself, as there was no such setting in the web server, the .htaccess files or the core_config_data table. When forwarding to HTTPS, though, it was referencing the wrong Document Root and therefore not finding the correct path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.