1

enter image description hereI have tried to remove layered navigation on www.example.com/checkout/onepage/ by adding checkout.xml 1 .first solution
<reference name="left"><remove name="catalog.leftnav"/> </reference> 2 . second solution <reference name="root"> <action method="setTemplate"><template>page/1column.phtml</template></action> </reference> 3. adding <remove name="left"/> at <checkout_onepage_index translate="label">

  1. added code at local.xml to make it 1column view <?xml version="1.0"?> <checkout_onepage_index translate="label"> <reference name="root"> <action method="setTemplate <template>page/1column.phtml</template></action> </reference> </checkout_onepage_index translate="label">

But it still remains there,I want to remove it only from checkout page only are keep it on other pages.What I have to do here ??? Please help ASAP.

15
  • 2
    what do you mean? the layered nav should not be there on the checkout page.
    – Marius
    Nov 25, 2015 at 12:57
  • are you kidding ?
    – Keyur Shah
    Nov 25, 2015 at 13:03
  • Share your website url????
    – Magento 2
    Nov 25, 2015 at 13:18
  • 1
    It's not layered navigation, it's your site's category tree, that your theme might have used to fancy up the things, please add code from your checkout.xml file. There should be some custom handle for calling that tree in there. You'll need to remove that. Or you can simply set your checkout page to 1 column and it will take care of the rest.
    – Prateek
    Nov 25, 2015 at 14:15
  • 1
    To those who voted this question "too broad" - you sure you're not just picking on someone who, not knowing Magento inside-out, can't be any more specific? It really isn't that broad. "I want to remove side navigation from the checkout page, how do I do it" - just because there may be a few ways to do it doesn't necessarily mean there are "too many possible answers". I count two sensible answers (one of which I've given below, the other would be <reference name="left"><remove name="catalog.leftnav"/></reference>). How the OP got into this position in the first place doesn't really matter. Nov 25, 2015 at 15:08

2 Answers 2

1

As Marius says it's unusual to have this showing on the checkout page. It may be that a third-party extension has overridden the default settings and applied the "two column left" layout on your checkout page. Setting it back to "one column" should do the trick.

You can try and find the XML file that's responsible in app/design/frontend/[package]/[theme]/layout and change that, but an easier way would be to create your own local.xml (app/design/frontend/[package]/[theme]/layout/local.xml). It should contain the following:

    <?xml version="1.0"?>
    <layout version="0.1.0">
        <checkout_onepage_index>
            <reference name="root">
                <action method="setTemplate"><template>page/1column.phtml</template></action>
            </reference>
        </checkout_onepage_index>
    </layout>

This should take priority over all the other XML files in the layout directory.

Note: obviously if you already have a local.xml file, don't just overwrite it with the above, you'll need to fit the checkout_onepage_index node in to the appropriate place. If you need help with that, share the current contents of that file.

Edit

Now your question has been edited I can explain a little further.

Points 1, 2 and 3

It looks as if all these changes you make to checkout.xml are being ignored. This is probably because another XML file has been introduced and is being loaded after checkout.xml, thus overriding it. The order in which Magento loads its layout files can be complicated and I won't go into detail here, suffice to say that local.xml is the last one it loads and therefore takes precedence over everything else. So your options are to try and track down the XML file that's added the left column into your checkout page, and change that, or simply to set it back to one column in local.xml.

Point 4

Given the above, why is your fourth attempt not working? It's because your XML is malformed, and in a number of places. You're missing the opening and closing <layout> tags (XML documents must always have a root element, and in this case that's <layout>), you have an attribute in your closing <checkout_onepage_index> tag, and it looks like there are some " and > characters missing. When in doubt, open your XML file in a browser and it should tell you about any errors it finds.

5
  • <?xml version="1.0"?>catalog_category_default><reference name="root"><action method="setTemplate"><template>page/2columns-left.phtml</template></action><reference name="root"><action method="setTemplate"><template>page/2columns-left.phtml</template></action></reference></catalog_category_layered><catalogsearch_result_index translate="label"><label>Quick Search Form</label><reference name="root"><action method="setTemplate">template>page/1column.phtml</template></action></reference></catalogsearch_result_index></layout></reference></catalog_category_default><catalog_category_layered> Nov 25, 2015 at 15:03
  • above code is local.xml.do you need anything else as well ?? Nov 25, 2015 at 15:08
  • Looks like there may be a few things missing in your local.xml (e.g. the <layout> tags to name one) but these comment fields make it hard to be sure. Are you able to edit your question and add it in there instead? Nov 25, 2015 at 15:13
  • Are you able to edit your question and add it in there instead? sorry sir what you are expecting here ??? Nov 25, 2015 at 15:16
  • I'm guessing you're not too familiar with the formatting options (AKA "markdown") in stackexchange.com. Comments aren't a great place to put example code as there's not really enough length and you can't do multi-line formatting. Whereas if you look at my answer above, you can see I've shared some XML code formatted in a way that makes it more readable. So, if you could edit your original question and include your XML there, and use the {} button in the toolbar to format it as code, then I can help identify any problems. Nov 25, 2015 at 16:55
0

You can set 1column.phtml template in your checkout.xml. Change the default template like below:

<checkout_onepage_index translate="label">
....
    <reference name="root">
        <action method="setTemplate"><template>page/1column.phtml</template></action>
    </reference>
</checkout_onepage_index>
1
  • It already have this code.... Nov 25, 2015 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.