0

I'm using this module to replace webservicex currency rates importer: https://github.com/philwinkle/Philwinkle_Fixerio

It is working ok when I hit import and save in the backend.

But I want to run it via a cron.

So I added to the module's config:

<crontab>
    <jobs>
        <fixerio>
            <schedule>
                <cron_expr>* * * * *</cron_expr>
            </schedule>
            <run>
                <model>fixerio/import::_convert</model>
            </run>
        </fixerio>
    </jobs>
</crontab>

And then run it with magerun:

./n98-magerun.phar sys:cron:run fixerio

It appears ok in the database and don't get errors in the console.

But the rates aren't modified in System -> Manage currencies.

If I insert a random value and save it then after the cron it will not update.

Any ideas? Thanks!

0

You should manage the currency import in System -> configuration -> manage currencies.

0

You probably want to change your cron schedule to <cron_expr>0 * * * *</cron_expr> once an hour instead of checking every minute.

Maybe the cron process isn't pulling through the fixer.io key? This could be a store scope issue. Cron process with use admin store values unless coded otherwise.

Although you shouldn't need this XML. This extension uses the built in magento cron process

Import the rates nightly by setting up the job to do so. Navigate to System > Config > Currency Settings > Scheduled Import Settings and select Fixer.io from the dropdown. Also enable the service if not previously enabled.

Schedule

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.