0

I have a link in static block footer which is <a href="{{store url="affiliate/account/create/"}}">Affiliates</a>. It's working fine in my local server but when I uploaded it to live it'snot redirecting ..It's getting stopped at my controller url www.mydomain.com/affiliate/account/create/ and showing blank page. I have already checked for typos. What else could be the problem?

 public function createAction() {           
        $this->loadLayout();
        $this->renderLayout();
    }

EDIT: noticed all my controller links to that particular controller file are not working only one template file which I had in dashboard which doesn't require controller to load is running properly other than that all the links related to controllers are not running (500 internal error showing in the browser console).

  • share your url? – Magento 2 Nov 25 '15 at 9:23
  • sorry i don't think i will be able to share the url. but i can provide you with code and screenshots if any needed. – Akash Nov 25 '15 at 9:27
  • Check controller and layout files of both local and live servers. There must be something missing from that. My guess would be the layout file. If it's not generated, it will show a blank page with header and footer only. – Prateek Nov 25 '15 at 9:58
  • in my case header and footer are also not being shown only white blank page. seems like browser is not even hitting controller . – Akash Nov 25 '15 at 10:09
0

correct use of variables is:

<a href="{{store url="affiliate/account/create/"}}">Affiliates</a>
  • tried but still not working even after clearing cache. – Akash Nov 25 '15 at 9:01
  • for client I use: <a href="{{store url="client/account/login/"}}">Account Registration</a> – Pier Nov 25 '15 at 9:09
  • hmm i see but it's not even showing 404 page. – Akash Nov 25 '15 at 9:14
0

You can check following checklist:

  1. Before clicking on link, Open "Firebug" and go to network tab. Are you able to get 200ok request from server?? Is there any error? what is your refer url in your request?

  2. Are you using SSL in your live server? if yes then check either your url adding HTTPS in url

  3. have you done any modification in affiliate/account/create module? can you please share this controller code? you have to debug your controller code.

  4. Go to index.php and enable developer mode and uncomment init_set then click on link

    //if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
    Mage::setIsDeveloperMode(true); //}
    

    ini_set('display_errors', 1);

  5. Login to admin panel > system > configuration > advanced check in all module list either your affiliate module is enabled or not. Thanks!

  • It's giving me 500 error. no modification done it's still running good on my local. – Akash Nov 25 '15 at 9:56
  • 500 internal server error right? So I think it's break at your controller. Is Affiliate is third party module are you using? Go to admin panel > system > configuration > advanced and check either your module is enabled or not. – satish Nov 25 '15 at 10:35
  • I have added one more checklist point in my answer. Try it. – satish Nov 25 '15 at 10:43
  • no it's not a third party i have created that module myself and its enabled in the backend – Akash Nov 25 '15 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.