1

I'm having issue with my log_customer & log_visitor_online tables, both are empty and aren't saving/updating any records for transactions.

All the other log tables are working well & are updating the data, so Log is not disabled & also core_config_data has a value 1 for dev/log/active

2
  • See if you have any logs in var folder related to this. Sometimes, Log module suffers from some foreign key violations and tables remain empty.
    – Prateek
    Nov 24, 2015 at 9:53
  • system & exception logs are enabled from admin panel but nothing in them related this issue
    – Ahmed
    Nov 24, 2015 at 10:14

2 Answers 2

2

found the issue, Enable Log was set to Visitors Only in Admin > Configurations > System > Log > Enable Log

It should set to Yes if you need customers Log and No if you don't need Logs

1

Check if System > Configuration > Advanced > Mage_Log is enabled. Check if log observers are disabled in you local.xml or in some external module. Below are the xml configuration to check if are enabled:

 <frontend>
    <events>
        <controller_action_predispatch>
            <observers><log><type>enabled</type></log></observers>
        </controller_action_predispatch>
        <controller_action_postdispatch>
            <observers><log><type>enabled</type></log></observers>
        </controller_action_postdispatch>
        <customer_login>
            <observers><log><type>enabled</type></log></observers>
        </customer_login>
        <customer_logout>
            <observers><log><type>enabled</type></log></observers>
        </customer_logout>
        <sales_quote_save_after>
            <observers><log><type>enabled</type></log></observers>
        </sales_quote_save_after>
        <checkout_quote_destroy>
            <observers><log><type>enabled</type></log></observers>
        </checkout_quote_destroy>
    </events>
</frontend>
4
  • Mage_Log is enabled & I didn't found <frontend> tag in my app/etc/local.xml Thanks
    – Ahmed
    Nov 24, 2015 at 9:20
  • The only thing disabling modules from admin does is stop block output anyway, the rest of the module continues to work as before. Nov 24, 2015 at 9:26
  • Try adding that xml before the </config> in the local.xml, clean the cache and test logs. Nov 24, 2015 at 9:43
  • nothing happened
    – Ahmed
    Nov 24, 2015 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.