0

All forms of my store stopped working after base url(secure and insecure) was changed to use https.

E.g.: Login stops on blank page [base_url]/account/loginPost/referer/[form_key] OR Reload the page and present no errors.

Through chrome inspector, I can see two requisitions, one using POST method and the other using GET method.

enter image description here

enter image description here

Anyone know something about that?

Ps: cache disabled

  • check form action http:// or https:// – Magento 2 Nov 20 '15 at 19:03
  • All actions are https. – Leonardo Ortiz Nov 20 '15 at 19:57
  • share me url and form action – Magento 2 Nov 20 '15 at 20:01
  • I Updated the question with prtscrns – Leonardo Ortiz Nov 20 '15 at 20:07
  • can you plz share your website url – Magento 2 Nov 20 '15 at 20:12
0

either your rewrites are incorrect, some template customizations or you modified controller in wrong way. this page is working properly:

https://www.ajhotel.com.br/index.php/customer/account/create/

make sure your .htaccess file dont have any weird rewrite rules, also check if mod_rewrite is working properly.

try to disable rewrites in magento to debug this issue.

Web > Search Engine Optimization > Use Web Server Rewrites

or enable it, just to be sure.

enter image description here

| improve this answer | |
  • It was enabled, now I disable it and comment lines in .htaccess, doing some tests, but apparently it is something with the .htaccess rewrite. Could you suggest me any .htaccess file for magento https? – Leonardo Ortiz Nov 21 '15 at 17:00
  • there is no need anything special. this is default .htaccess file must work svn.magentocommerce.com/source/branches/1.9/.htaccess – MagenX Nov 21 '15 at 19:07
0

After tons of search, found this post here:

Frontend login not working in Chrome with https enabled (1.9)

The 'solution' was: set the Cookie Lifetime to 0 in Backend, and(of course), clear browser cookies.

It seems to happens only in Chrome, 'cause through Firefox(the only other browser that I tested), it works normally.

Still searching for a best solution and more answers though.

| improve this answer | |
-1

See your Configuration > General > Web > Secure section and cooke section to adjust settings.

In secure: Change to Use Secure URLs in Frontend to On In Cookie: try with Use HTTP Only off

| improve this answer | |
  • Did it, not has changed :/ – Leonardo Ortiz Nov 20 '15 at 21:17
  • Clear cookies and retry – Imaginaerum Nov 20 '15 at 21:18
  • Same thing. Also, don't know why, when go to ajhotel.com.br/customer/account, it add referer/aHR0cHM6Ly93d3cuYWpob3RlbC5jb20uYnIvY3VzdG9tZXIvYWNjb3VudC9pbmRleC8,/ to the url – Leonardo Ortiz Nov 20 '15 at 21:23
  • Try to remove sid to url Admin == System == Configuration == Web == Session – Imaginaerum Nov 20 '15 at 21:27
  • It's already on 'no' – Leonardo Ortiz Nov 20 '15 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.