1

Tried installing Magento 2 using setup wizard. All the checks were correct and installation was completed till 90%. After that it did not show any progress for many hours. When I run the http://localhost/magento_2, it takes forever to load and prints 503 error.

Service Unavailable_img

As mentioned here I tried debugging as Apache 2.4 changes the way certain directives related to .htaccess work.

Suggested solution on website

As a user with root privileges, enter the following commands:

a2enmod access_compat
service <name> restart

How do I debug this issue on my local WAMP server and succesfully install Magento 2 with sample data ?

1

See the browser console for JavaScript and asynchronous HTTP errors.
Also never install Magento on a top-level domain like localhost because, in contract to other CMS, Magento does not work properly on a top-level domain.
Use something like localhost.com instead.

  • localhost.com is not the best name either because it is a real host, which redirects to google BTW – Alex Paliarush Nov 19 '15 at 18:44
  • There is no any JavaScript and asynchronous HTTP errors.In apache error console it shows PHP Fatal error: Maximum execution time of 30 seconds exceeded. but i have already set max_execution_time = 18000 in php.ini file. – Bijal Nov 20 '15 at 5:27
  • It seems that your max_execution_time setting has not been applied. Do call phpinfo() function from the Magento 2 website root and see the actiual max_execution_time vaue for Magento 2. – Mage2.PRO Nov 20 '15 at 5:53
  • I have called phpinfo() function and checked max_execution_time in it,It shows me max_execution_time=18000. – Bijal Nov 20 '15 at 6:24
  • memory_limit is also important and should be at least 768M. devdocs.magento.com/guides/v2.0/install-gde/prereq/… – Steve Johnson Nov 20 '15 at 12:58
1

Could you enable the developer mode from the .htaccess file, or you can enable it from the cli

bin/magento deploy:mode:set developer

to let us see what's going on :)

1

I got the same error. Firstly to get rid of the 503 error:

Clear var/cache, var/page_cache, var/generation. After that assign 777 permission to pub/, var/ and app/etc/ folders.

Now, this type of error usually occurs because of the mySQL timeout. You can try increasing mySQL timeout by increasing max_execution_time . However, this may or may not work. So you can try installing Magento 2 using Command line interface. Command for it is as below:

sudo php -dmemory_limit=1G bin/magento setup:install --base-url=http://myip/myfoldername --backend-frontname=admin --admin-firstname=Admin --admin-lastname=Admin --admin-email=test@example.com --admin-user=admin --admin-password=mypwd --db-host=localhost --db-name=mydbname --db-user=mydbuser --db-password=mydbpwd

Also some points to note: avoid using localhost URL when installing magento2. You should use IP instead. Before starting installation, assign full permission to app/etc/, var/ and pub/ folders.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.