5

I try to install Magento2 in My local system but I got PHP Extension intl error

enter image description here

8

Open php.ini file and find the line ;extension=php_intl.dll and remove semicolon (;) and save the file and then restart your xamp or wamp server and refresh the installation page.this error will be gone.

Note:- for more information on the above error see http://pradeepsanku.com/2015/11/20/php-intl-extension-is-missing-during-installation-of-magento-2-magento-2/

PHP Extension intl is missing

;extension=php_intl.dll

Un comment the line from both php.ini

1.  \wamp\bin\apache\apache2.4.9\bin
2.  \wamp\bin\php\php5.5.12

And search for .dll files in \wamp\bin\php\php5.5.12 start with icu i.e. icuxxx.dll copy all these files(around 8 files) and paste/replace in \wamp\bin\apache\apache2.4.9\bin

Restart the wamp & recheck readiness check.

  • I've uncomment the line but still getting extension is missing. My PHP version is 5.5.12 – Kailas Dec 21 '15 at 4:56
  • after uncomment you have to restart your apahe server.have you did this ? – Pradeep Sanku Dec 21 '15 at 5:25
  • yes. but not working. Check @Neeraj Garg answer point no 3 is work for me. – Kailas Dec 21 '15 at 6:22
7

Yes, Magento 2 was released today.

You're missing a PHP extension. I don't know your setup, but on Ubuntu with Apache you can install the missing extension with:

sudo apt-get install php5-intl

After that you should reload apache

sudo service apache2 restart
  • actually i tried to instal in my local system How i check this – Magento 2 Nov 18 '15 at 14:51
  • You can check this post that contains the same missing extension as you do: stackoverflow.com/questions/26285280/…. But as KAndy pointed out, you could beter use Vagrant for Magento2 development. – Silvan Nov 18 '15 at 14:59
2

For windows:-

1. xampp version

assuming you are using latest version of xampp. can be download from here:-

https://www.apachefriends.org/download.html

2. php.ini

If you are using Xampp on local you can find the php.ini at /xampp/php/php.ini

In this file search for

;extension=php_intl.dll

and changed this to

extension=php_intl.dll (remove semicolon from front)

3. .dll files

go to xampp/php and search for .dll files start with icu i.e. icuxxx.dll

copy all these files(around 8 files) and paste/replace in xampp/apache/bin

Now try again with installation. This should work.

1

I had the same problem a few days ago.
Setp 1:- You have to copy all the files (all files starts with icu*):
From: /bin/php/php5.4.3/

icudt.dll
icudt46.dll
icuin.dll
icuin46.dll
icuio.dll
icuio46.dll
icule.dll
icule46.dll
iculx.dll
iculx46.dll
icutest.dll
icutest46.dll
icutu.dll
icutu46.dll
icuuc.dll
icuuc46.dll

Setp 2:- Copy here To: = /bin/apache/apache2.2.22/bin/

Setp 3:- And you also need to enable intl in php.ini file (uncomment this line):

;extension=php_intl.dll

=> And restart the server. It should works fine. :)

1

For removing PHP Extension intl error, we have to enable PHP Extension intl , follow the Steps..

Open the xampp/php/php.ini file in any editor.
Search ";extension=php_intl.dll"

kindly remove the starting semicolon ( ; )

Like :

;extension=php_intl.dll

to

extension=php_intl.dll

Save the xampp/php/php.ini file.
Restart your xampp/wamp

Hope its work..Cheers..

0

Installing Wamp 2.5 on windows 8 if you do not need to change the default port 80 go to control panel->administrative tools->services search for world wide web publishing service which is the second last usually and click on stop and set to disable for permanent basis.restart your Wamp and its done.

Answer 3 solved my problem I am using Wamp version 2.5.

0

You need to edit the php.ini at /xampp/php/php.ini

search for

;extension=php_intl.dll

and change this to

extension=php_intl.dll (remove semicolon from front)

after save the file, you need to re-start your Xampp.

Not the answer you're looking for? Browse other questions tagged or ask your own question.