2

Hello I have a problem with my custom module that I have created. I have backed up my magento through Admin panel then looked at the page later on and this has come up. I can see the header but can't see the content. I haven't done any changes to the files. A lot of people said it could be because of the compilations so I have disabled it and cleared cache, nothing happened.

This is my Basic class:

<?php
  class Bundle_LocalHelpers_Helper_Basic extends Mage_core_Helper_Abstract {}

And this is my config.xml :

<?xml version="1.0"?>
<config>
<modules>
    <Bundle_LocalHelpers>
        <version>0.1.0</version>
    </Bundle_LocalHelpers>
</modules>
    <global>
        <helpers>
            <localhelper>
                <class>Bundle_LocalHelpers_Helper</class>
            </localhelper>
        </helpers>
    </global>
 </config>

It was working perfectly fine. I have also checked other questions but didn't find the right answer.

  • Is this all you have in your config.xml? Any routers? If not replace <localhelper> with <Bundle_LocalHelpers> – Yiorgos Moschovitis Nov 18 '15 at 13:24
3

You write it worked, so I assume the config.xml is loaded.

And I assume you call the helper via Mage::helper('localhelper').

And I assume your helper lives in app/code/community|local/Bundle/LocalHelpers/Helper/Data.php

If this is all the case it is a hard nut to crack.

Start by making sure your etc/modules.xml is loaded, just break the XML and in dev mode you see a simple_xml error. If you see it, break the config.xml and make sure you see the same error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.