2

My current version of Magento is 1.9.2.1. I'm using "Easylife Switcher" to make the first option of each attribute selected automatically. I'm also using the "Product attribute order fix" to have all options ordered correctly according to my default settings.

When I import products with Magmi (v0.7.22_git) everything works fine (apparently) until the 10th configurable product. Each configurable product have 220 Simple Products.

This is how the options box looks like up to the 10th configurable product:

enter image description here

Everything is as it should be!

After the 10th configurable product:

enter image description here

After the 10th all the products have the same error. If i disable the "Product attribute order fix" I can see that the options being automatically selected are the first of each attribute without my default order.

Live examples:

Good: http://www.teelegend.com/catalog/product/view/id/2200

Bad: http://www.teelegend.com/catalog/product/view/id/2860

Can somebody help me? I'm really having a hard time trying to figure this out.

closed as off-topic by Marius Mar 2 '16 at 9:48

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions about third-party modules are generally off-topic because the scope of functionality and code are not available. For more information, see this meta post/answer." – Marius
If this question can be reworded to fit the rules in the help center, please edit the question.

1

Those plugins typically use javascript to select a particular configuration. On the page you link as "good", I get a jQuery is not defined error. I assume this is not related as it's on the "good" page. However, on the "Bad" page, I also get these three javascript errors:

Uncaught TypeError: Cannot read property 'config' of undefined
Uncaught TypeError: Cannot read property 'value' of undefined
Uncaught TypeError: Cannot read property 'config' of undefined

So, seeing how these errors only show on the "bad" page, I'd say it's a good clue.

If you click around on the vertical 'icon bar', you'll see these errors output again in the browser. It appears as though it's trying to select a tab on this icon bar, errors and cannot continue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.