when i install magento 1.9.2 get error

Error in file: "C:\localhost\magento-192\app\code\core\Mage\CatalogRule\sql\catalogrule_setup\upgrade-" - SQLSTATE[42000]: Syntax error or access violation: 1091 Can't DROP 'website_ids'; check that column/key exists

. I tried several times without success. i think MySQL server run import slow. so i want file database-simple.sql.

1 Answer 1


Simply drop the database and recreate. Magento will do the rest by itself.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. - From Review
    – 7ochem
    Nov 16, 2015 at 11:41
  • This is the solution, Magento create tables when installation process occurs. Magento shows this kind of errors whenever installation process left incomplete or php execution limit exceeds. Magento saves modules list in a table which also saves module version. This problem can also be rectified by recreating the database. Magento will create all tables again. Or drop catalogrule record from core_resource table. Nov 16, 2015 at 12:12
  • when i install again get error The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
    – xanka
    Nov 17, 2015 at 1:51
  • @xanka Check if there is a file called maintenance.flag in your magento root. If so Delete it. Nov 17, 2015 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.