1

I am new in magento i want to create a Hello World Module i am follow many tutorial but i am always getting 404 error

My app/etc/module file

<?xml version="1.0"?>
<config>
    <modules>
        <Quinchy_Demo>
            <active>true</active>
            <codePool>local</codePool>
        </Quinchy_Demo>
    </modules>
</config>

My Php clas file in app/code/local/Quinchy/Demo which is

<?php

class Quinchy_Demo_IndexController extends Mage_Core_Controller_Front_Action{

    public function indexAction()
    {
        echo "Hello Quinchy";
    }
}
?>

and config file is

<?xml version="1.0"?> 
<config>
    <modules>
        <Quinchy_Demo>
            <version>0.1.0</version>
        </Quinchy_Demo>
    </modules>    
    <frontend>
        <routers>
            <quinchy>
                <use>standard</use>
                <args>
                    <module>Quinchy_Demo</module>
                    <frontName>quinchy</frontName>
                </args>
            </quinchy>
        </routers>
    </frontend>    
</config>

and i calling this Module using this URL

127.0.0.1/magento/index.php/quinchy,
127.0.0.1/magento/quinchy/
127.0.0.1/magento/quinchy/index

File Structure please help me

5
  • You have a typo on the name of the models folder. It should say Model, not Modal.
    – user12795
    Nov 15 '15 at 3:45
  • ok i changed it but still i am facing same error Nov 15 '15 at 3:55
  • Did you check if you're getting any error in your log file (var/log/system.log)?
    – user12795
    Nov 15 '15 at 4:40
  • I just added your sample code to a fresh Magento install and it worked. Did you flush your cache?
    – user12795
    Nov 15 '15 at 5:25
  • yes i flush and also remove all folder from var Nov 15 '15 at 5:38
1

There must be a user permission issue of the your file . The configuration and setup of the folder looks fine . Please check the permission .

1

You code is seems to right.

  • May be magento compiler is enable at your system.You need to recompile in order execute the module

  • Or as rahul said,Please check file permission.

To know more about compiler.please check

http://support.createhosting.co.nz/knowledgebase.php?action=displayarticle&id=49

http://alanstorm.com/magento_compiler_path

4
  • from log i am getting this Entity: line 2: parser error : Start tag expected, '&lt;' not found in C:\xampp\htdocs\magento\lib\Varien\Simplexml\Config.php Nov 15 '15 at 6:06
  • i am running it on windows Nov 15 '15 at 6:13
  • the there some space is xml file .... Before starting <?xml tag.... ,there are may be some space available
    – Amit Bera
    Nov 15 '15 at 7:00
  • May be some space issue in xml files .... Before starting <?xml tag.... ,there are some space available.That reason it show error
    – Amit Bera
    Nov 15 '15 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.