i can't get rid of the discount and estimate code at checkout in Magento 1.9. I removed the code from : /app/design/frontend/your_package/mytheme/layout/checkout.xml tried even with core files and still keeps showing it, i always remove the discount code like this with no problems but for some reason i can't now.

Also tried App --> Design --> Frontend --> Base -- > Default --> Template --> Checkout --> cart.phtml and comment "getChildHtml('coupon') ?>

I am really clueless, any help would be appreciated.

| improve this question | | | | |

First thing to check is that you have caching and compilation disabled so that the changes you are making are reflected in the live site.

You can hide the block in the CSS via:

.checkout-cart-index .discount { display: none; }

Ideally, this would be done via the local.xml file in your theme's layout folder:

<?xml version="1.0" encoding="UTF-8" ?> 
        <remove name="checkout.cart.coupon"/>       
| improve this answer | | | | |
  • Hi thx for your message, it worked!!! You the man. Thx again :) – Mido Nov 16 '15 at 17:54
  • Happy to help! If you click on the checkmark to the left of the answer to accept my answer, that will help others looking for the same solution. Cheers. – ReDesigned Nov 17 '15 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.