1

I'm still figuring Magento out just wasted 2 hours searching how to remove the newsletter block from the footer in the RWD theme (I'm using a child theme of this).

Here is my app/design/frontend/rwd/mytheme/layout/local.xml

    <?xml version="1.0"?>
<layout>
<default>
<reference name="head">
    <action method="removeItem"><type>skin_js</type><name>js/slideshow.js</name></action>
    <action method="removeItem"><type>skin_js</type><name>js/lib/jquery.cycle2.min.js</name></action>
    <action method="removeItem"><type>skin_js</type><name>js/lib/jquery.cycle2.swipe.min.js</name></action>
    <action method="removeItem"><type>skin_css</type><name>css/madisonisland.css</name></action>
    <action method="removeItem"><type>skin_css</type><name>css/madisonisland-ie8.css</name></action>
    <action method="addLinkRel"><rel>stylesheet</rel><href>//fonts.googleapis.com/css?family=Raleway:300,400,500,700,600</href></action>
    <action method="addlinkRel"><rel>stylesheet</rel><href>css/custom.css</name></href></action>
    <action method="addlinkRel"><rel>stylesheet</rel><href>css/what-we-buy.css</href></action>
</reference>

<reference name="footer">
    <remove name="footer.newsletter" />
    <remove name="footer_links" />
    <remove name="footer_links2" />
</reference>


</default>
</layout> 

but nothing changes. I think everything in the 'head' section is applying since I do not see any of that when I ->view source. I even tried removing

    <!-- Mage_Newsletter -->
    <reference name="footer">
        <block type="newsletter/subscribe" name="footer.newsletter" as="newsletter" before="footer_store_language" template="newsletter/subscribe.phtml"/>
    </reference>

from newsletter.xml but even that doesn't work. I have flushed the cache multiple times as well. None of the other blocks remove from footer either.

So the question is, what am I not understanding and how do I remove the newsletter box from the footer in 1.9 RWD theme?

Edit: Added my local.xml info. Also, removing code directly from newseltter.xml (or page.xml for other footer blocks) does seem to work when cache is disabled. I know this is not the correct way though.

3

Create a file app/design/frontend/rwd/default/layout/local.xml

and add the following contents:

<?xml version="1.0"?>
<layout>
<default>
        <reference name="footer">
                <remove name="footer.newsletter" />
        </reference>
</default>
</layout>

It may be that you were doing it in a XML file before the newsletter template had actually been loaded, or if you were doing it in a local.xml file you had the wrapper tags missing, but I've just verified on a clean install of 1.9 and it's working as it should.

  • Ahh sorry for not being more clear. My local.xml looks exactly like what you put, but does not effect anything. I have it in app/design/frontend/rwd/mytheme/layout/ – k1rah Nov 15 '15 at 2:36
  • Make sure you refresh the layout and block cache after making the change. – Eirik Nov 15 '15 at 3:18
  • @k1rah - you say you've put it in rwd/mytheme - but have you then told Magento to use that theme? If you create your own design, you need to tell it to use that design rather than the default. Take a quick look at templatemonster.com/help/… to see how to change it. Otherwise, if you have not told it to use a different design, then put the local file in the default directory as per my original answer. – Liam Wiltshire Nov 16 '15 at 16:16
  • Yes, I have done this. Package is set to rwd, and all the theme entries are set to my custom theme. It is only a very minor customized theme of rwd, but it seems nothing in the local.xml that I posted above is applying. – k1rah Nov 17 '15 at 18:06
1

I stumbled upon this answer to a user with related issue

https://magento.stackexchange.com/a/5535/21254

And it was an error in my xml! There was an extra tag that shouldn't have been there.

1

Not sure what version of Magento this was for but after I followed app/design/frontend/rwd/default/layout/local.xml on my 1.9.3.1 there was no local.xml but a bunch of other *.xml one named newslettter.xml. So after renaming that file the newsletter link was removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.