This permissions issue comes up in the server log. It doesn't stop the site from loading but it does stop a lot of the site from functioning. Some things I did fix through permissions but things like this keep popping up and I'm not sure if it is an Apache thing with rewrites or if this is a permissions issue. There's not supposed to be a htaccess file in this folder correct?

/pub/static/adminhtml/Magento/backend/en_US/mage/utils/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that ... is executable

also errors for:


I've gone all the way to 777 on files and folders in /en_US/ just to test and still same issue

What steps should I take to narrow this issue down? What permissions does pub/static/ need in order to function? Also, if a mod_rewrite issue, how can I enable this for the root magento directory without doing in the httpd.conf file? When I look for mod_rewrite, I am not having any luck finding a way to ensure it is in fact enabled and working.

I have

  • PHP 5.6.15
  • Apache 2.4.16
  • Easy::Apache v3.32.5 rev 9999
  • MySQL 5.6.27
  • Magento 2.0.0-rc.

httpd.conf directory setting:

AllowOverride All Options All

Options All AllowOverride All Require all granted

AllowOverride All Options All Require all granted

1 Answer 1


The web server user must have write access to the following files and directories:

  • var
  • app/etc
  • pub

Magento also recommends setting the permissions as follows:

  • All directories have 770 permissions. 770 permissions give full control (that is, read/write/execute) to the owner and to the group and no permissions to anyone else.
  • All files have 660 permissions. 660 permissions mean the owner and the group can read and write but other users have no permissions.

source: http://devdocs.magento.com/guides/v2.0/install-gde/install/file-system-perms.html

In terms of the mod_rewrite issue in your .htaccess you should be able to change RewriteBase / depending on you configuration.

see: https://github.com/magento/magento2/blob/develop/.htaccess#L151

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.