6

On some of my websites I use this code:

{{block type="catalog/product_list" name="home.catalog.product.list" alias="products_homepage" template="catalog/product/list.phtml"}}

It works fine on three websites but on one website it doesn't work. I use it in a static block. This static block is displayed on the category pages.

After some testing it seems that almost every line of code with block type is not working. I tried displaying another category and such but with no luck.

7

The three websites where it works probably have a bigger problem than the one where it doesn't: they do not have the recent security patch SUPEE-6788 applied.

One thing that the patch changed was that blocks to be used in CMS directives like that have to be added to a whitelist. You find this whitelist in System > Permissions > Blocks.

More details in this question: APPSEC-1057 How to add variables or blocks to the white list tables

  • Last week they worked fine on the website but suddenly it stoped working. I didn't install any update in that week. – FuriousBas Nov 10 '15 at 10:34
  • Maybe somebody else did. To be sure, check: magento.stackexchange.com/questions/64204/… – Fabian Schmengler Nov 10 '15 at 10:36
  • I whitelisted the block and it now seems to work. So why it worked last week is unknown to me. – FuriousBas Nov 10 '15 at 10:50
  • OMG - I tried to solve this problem the whole day now.... and the solution was so "easy". I upgraded my DEV-server from 1.8 to 1.9 and thought it had something to do with new APIs. THANK YOU! – cljk Nov 13 '15 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.