0

I am using Magento Go and I had my logo set but when I set an updated version of it, I am still seeing the old version on the front-end. Why is this? It appears that I cannot flush the cache in Magento Go, and I have already cleared my browser's cache. I have also tried renaming the file and re uploading it but this didn't work either. It appears to be loading from the CDN.

Response Headers:
HTTP/1.1 200 OK
Accept-Ranges: bytes
Content-Type: image/png
Date: Wed, 09 Oct 2013 12:41:15 GMT
Last-Modified: Tue, 10 Sep 2013 15:55:08 GMT
Server: ECS (jfk/5F35)
X-Cache: HIT
X-Server: w81
Content-Length: 2300

closed as off-topic by Marius Feb 1 '15 at 21:38

  • This question does not appear to be about the Magento e-Commerce platform within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is the image loading from the same URL as the site or from a CDN? Could you post the response headers for the image req? Might help...they can be obtained from the web inspector in your browser. – davidalger Oct 7 '13 at 1:32
  • @davidalger I updated my question with the info. – tacudtap Oct 9 '13 at 12:49
  • Pat, with it loading from a CDN, this actually makes some sense. CDN delivered assets typically can take quite a bit of time for changes to roll out. If you'll notice in the response headers, the CDN believes the last modification time was the 10th of September, as the new image hadn't yet propagated. Go probably flags it as out of date, and then the asset has to be refreshed by the CDN servers to actually change on the frontend of the site. – davidalger Oct 10 '13 at 22:25
0

There are 3 different scopes in magento configuration. Default/Website/Store view

It's possible that you updated your logo for "Default" scope, but this setting is overwritten for "Store view" scope. Many chances this is the case.

  • I don't see any option about scope where the logo is entered. How can I specify scope when uploading the logo? – tacudtap Oct 4 '13 at 18:09
  • Ah, sorry I missed that you're using Magento GO. Okay, I still have an idea: try to change logo's filename and then reupload. Maybe your hosting caches static assets like images by filename. – Alexey Shchur Oct 4 '13 at 19:57
  • Sorry @Rob, I forgot to add to my question that I had already tried that. – tacudtap Oct 5 '13 at 14:45
0

Not used Magento Go in a while, but there must be a way to refresh the cache? Rename or delete the var/cache folder?

  • Magento Go is SaaS based and this access to the file system is naturally not granted. Not sure about the cache flushing being available or if it's all automatic on save or frequency. – davidalger Oct 7 '13 at 1:31
  • I have not found any way to do this and I've done some research on it with no results. – tacudtap Oct 7 '13 at 13:57
  • From memory, going back at least 18 months, I grew frustrated with lack of flexibility with Magento Go to not be able to update things like this, and just bit the bullet and installed Magento CE. The Magento Go support area that looks to hold the answer (from Google search) just redirects to the magento Go homepage area...... – MagentoMac Oct 7 '13 at 18:26
-1

I ended up reuploading my logo a third time. It finally worked. I have no idea why it didn't work the first two times. Thanks for everyone's input.

Not the answer you're looking for? Browse other questions tagged or ask your own question.