0

This question has been answered before, but none of the answers work for me, and the questions are old so I didn't just want to add a Me To. Here is my specific situation:

Production server on a shared host, Magento 1.7.0

I am trying to create a test environment in preparation for updating the site to 1.9.2. I did the following:

  1. disabled and flushed all caches
  2. made a backup of the database using mysqldump
  3. created a new database
  4. loaded the new database from my backup using mysql
  5. created a new directory for the test environment magento-1.7.0, production is in magento
  6. copied production site to test environment using cp magento/ magento-1.7.0/
  7. set pointers to the new database in magento-1.7.0/app/etc/local.xml
  8. changed secure base url to https://test.mydomain.com in core_config_data
  9. changed unsecure base url to http://test.mydomain.com in core_config_data
  10. deleted magento-1.7.0/var/cache just to make sure it was gone
  11. deleted magento/var/cache just to make sure it was gone
  12. checked for compilation (none)
  13. checked /tmp/ for a magento directory or anything like it (none)
  14. tested my new environment by pointing my browser to test.mydomain.com (note - mydomain.com is not the real domain name)
  15. site still redirects to www.mydomain.com

I looked at the network response header in firefox, and found location: www.mydomain.com. The response code was 302. What else do I need to check for?

  • Did you check if your Magento store is using cache in db mode? If yes, the cache will be on core_cache_option. Or you can just change your local.xml to use files cache storage. – Denis Spalenza Nov 10 '15 at 2:59
  • All cache options are disabled. All the values in core_cache_option are 0. – jmarkmurphy Nov 10 '15 at 3:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.