2

I deleted all products by truncating tables. Now, after uploading all products again I get this:

    Product Attributes index process unknown error:

    exception 'PDOException' with message 'SQLSTATE[23000]: Integrity 
constraint violation: 1452 Cannot add or update a child row: a foreign key
 constraint fails (`XXXXXX`.`catalog_product_index_eav`, CONSTRAINT 
`FK_CAT_PRD_IDX_EAV_ENTT_ID_CAT_PRD_ENTT_ENTT_ID` FOREIGN KEY 
(`entity_id`) REFERENCES `catalog_product_entity` (`entity_id`) ON DELETE 
CASCA)'

How can I repiar the database now so eindex is working again? How can I find the right entities to delete?

4
  • Have you cleared cache and your Locks directory in the var folder? Commented Nov 9, 2015 at 14:06
  • What has this to do with an Database error while reindexing from the shell? The Error comes clearly from database. Commented Nov 9, 2015 at 14:09
  • Because I have had the same error and clearing the cache and locks folder and solved it Commented Nov 9, 2015 at 14:44
  • I strongly doubt that. Commented Nov 10, 2015 at 8:37

1 Answer 1

1

I was looking around a litte - not so easy to find but here is a solution: https://stackoverflow.com/questions/8111889/cant-re-index-new-products-after-upgrading-to-version-1-6/19837851#19837851

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.